Doing Homework again

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 
Output
For each test case, you should output the smallest total reduced score, one line per test case. 
Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
Sample Output
0
3
5
题意:有n个任务,每个任务有一个完成的期限和一个惩时,没有在规定期限内完成就会罚时,怎样安排任务执行顺序使得罚时最少
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct A{
    int a,b;
}f[1010];
bool cmp(A x,A y)
{
    if(x.b==y.b)
        return x.a<y.a;
    return x.b>y.b;
}
int main()
{
    int t,n,i,j,s,bj[10100];
    scanf("%d",&t);
    while(t--)
    {
        memset(bj,0,sizeof(bj));
        scanf("%d",&n);
        for(i=1;i<=n;i++)
            scanf("%d",&f[i].a);
        for(i=1;i<=n;i++)
            scanf("%d",&f[i].b);
        s=0;
        sort(f+1,f+n+1,cmp);
        for(i=1;i<=n;i++)
        {
            for(j=f[i].a;j>0;j--)//争取在期限那天完成任务,实在不行,就靠近期限完成,
                //然后将这一天标记为已用过,就不能再用这一天了,比如排好序之后第一个任务是扣7分的,
                //它可以在第四天完成,把第四天标记为用过,第二个任务可以在第二天完成,第二天也标记
                //第三个的期限是4天,但是但四天被任务1用了,所以它就选择在第三天完成喽,第三天标记,后面的一样处理
            {
                if(bj[j]==0)
                {
                    bj[j]=1;
                    break;
                }
            }
            if(j==0)//如果等于0了,说明要牺牲这个任务(被扣分),没办法,这已经是最贪心了
            s=s+f[i].b;
        }
        printf("%d\n",s);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值