poj1318

                                                                                                                                    Word Amalgamation

                                 

Description

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input

The input contains four parts: 1) a dictionary, which consists of at least one and at most 100 words, one per line; 2) a line containing XXXXXX, which signals the end of the dictionary; 3) one or more scrambled 'words' that you must unscramble, each on a line by itself; and 4) another line containing XXXXXX, which signals the end of the file. All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line "NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

                      做这个题目的时候,注意两点就可以了1.查找的时候,不要单个字符去比较,这样很容易出错,应该以字符窜为单位去逐一去做比较,有符合题意的就输出!

                                                                                               2,.有多个单词符合条件是要看清楚输出的顺序,所以在比较之间对字典的单词进行一次排序,这样比较轻松!!!

                 附一组数据:aabbcc

                                         bbccaa

                                         XXXXXX

                                         aaaaaa

                                          XXXXXX

                          输出应该是:NOT A VALID WORD

  具体代码如下:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char dic[101][7],che[101][7];
int cmp(const void *l1,const void *l2)
{
	return(strcmp((char*)l1,(char*)l2));
}
int cmp1(const void *l1,const void *l2)
{
	return *(char*)l1-*(char*)l2;
}
void main()
{
	int i,j,k1,k2;
	for(i=0;;i++)
	{
		scanf("%s",dic[i]);
		if(dic[i][0]=='X')
		{k1=i;break;}
	}
	for(i=0;;i++)
	{
		scanf("%s",che[i]);
		if(che[i][0]=='X')
		{k2=i;break;}
	} 
	qsort(dic,k1,sizeof(dic[0]),cmp);
	for(i=0;i<k2;i++)
	{	
		int flag=0,flag1=0,leni,lenj,k=0;
		char  che1[7]={'\0'};
	    leni=strlen(che[i]);
		strcpy(che1,che[i]);
		qsort(che1,leni,sizeof(che1[0]),cmp1);
		for(j=0;j<k1;j++)
		{   
		   char	dic1[7]={'\0'};
			lenj=strlen(dic[j]);
			if(leni!=lenj)continue;
		    strcpy(dic1,dic[j]);
			qsort(dic1,lenj,sizeof(dic1[0]),cmp1);
			if(strcmp(che1,dic1)==0)
			{
				printf("%s\n",dic[j]);
				k++;
			}
		}
         if(k==0)printf("NOT A VALID WORD\n");	
		printf("******\n");
	 }
}


          虽然简单,但什么都要认真对待,不是吗?

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值