UVALive 3266 田忌赛马

Here is a famous story in Chinese history.
That was about 2300 years ago. General Tian Ji was a high official in the country Qi.
He likes to play horse racing with the king and others.
Both of Tian and the king have three horses in different classes, namely, regular, plus,
and super. The rule is to have three rounds in a match; each of the horses must be used in
one round. The winner of a single round takes two hundred silver dollars from the loser.
Being the most powerful man in the country, the king has so nice horses that in each
class his horse is better than Tian's. As a result, each time the king takes six hundred silver
dollars from Tian.
Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals
in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver
dollars and such a grace in the next match.
It was a rather simple trick. Using his regular class horse race against the super class
from the king, they will certainly lose that round. But then his plus beat the king's regular,
and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji,
the high ranked official in China?
Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in
the ACM contest right now, he may discover that the horse racing problem can be simply viewed as
nding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's
horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge
between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds
as possible is just to nd the maximum matching in this graph. If there are ties, the problem becomes
more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and nd a maximum
weighted perfect matching...
However, the horse racing problem is a very special case of bipartite matching. The graph is decided
by the speed of the horses | a vertex of higher speed always beat a vertex of lower speed. In this case,
the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.
In this problem, you are asked to write a program to solve this special case of matching problem.
Input
The input consists of up to 50 test cases. Each case starts with a positive integer
n
(
n
1000) on the
rst line, which is the number of horses on each side. The next
n
integers on the second line are the
speeds of Tian's horses. Then the next
n
integers on the third line are the speeds of the king's horses.
The input ends with a line that has a single `
0
' after the last test case.
Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji
will get, in silver dollars.
SampleInput
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0
SampleOutput
200
0
0



这道题走入误区 写了超久

正确的方法是

先排序

田最快的马和齐最快的马比

1如果田快, 加200, 田和齐最快的马都--

2 否则

比最慢的马

田慢 》 齐慢

+200

否则 田慢vs 齐快

-200  或者-0



#include <stdio.h>
#include <stdlib.h>
#define N 1010
int x[N], y[N];
int cmp(const void *a, const void *b){
	return (*(int *)b - *(int *)a);
}

int main(){
	int n;
	while (scanf("%d", &n) != EOF && n) {
		int f1 = n - 1, f2 = n - 1, s = 0, sum = 0;
		for (int i = 0; i < n; i++)
			scanf("%d", &x[i]);
		for (int i = 0; i < n; i++)
			scanf("%d", &y[i]);
		qsort(x, n, sizeof(x[0]), cmp);
		qsort(y, n, sizeof(y[0]), cmp);
		for (int i = 0; i <= f1; i++) {
			if (x[i] > y[s]) 
				sum += 200, s++;
			else {
				if (x[f1] > y[f2]) 
					sum += 200, f1--, f2--, i--;
				else {
					if (x[f1] < y[s]) 
						sum -= 200, f1--, s++, i--;
					else 
						f1--, s++, i--;
				}
			}
		}
		printf("%d\n", sum);
	}	
	return 0;




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值