HDU 1260 Tickets (DP)

Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.


Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.


Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.


Sample Input

2
2
20 25
40
1
8



Sample Output

08:00:40 am

08:00:08 am


题意:k个人买票,告诉你每个人买票的时间,以及相邻两个人买票的时间,从上午8点开始卖,求用最短时间卖完票后的时间,,,比如示例,有两个人买票,分别用时20秒、25秒,但如果买双人票用时40秒,所以最少用40秒买完票,即时间为08:00:40  am,,,


思路:考虑两个人买票的情况,有两条路,一是单独买,二是买双人票,设dp[k]为买完第k张票花费的总时间,a[k]为单独买第k张票所需的时间,b[k]为买第k张双人票所需的时间,

则第一种情况(单独买)为 :dp[k]=dp[k-1]+a[k];

第二种情况(买双人票)为 :dp[k]=dp[k-2]+b[k];

故特性方程为:dp[k]=min(dp[k-1]+a[k],dp[k-2]+b[k]);

需要注意am、pm的判断,以及补0操作用%02d;


以下AC代码:

///dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
#include<stdio.h>
int min (int a,int b)
{
    return a<b?a:b;
}
int main ()
{
    int i;
    int h,m,s;
    int a[2005],b[2005];
    int dp[2005];
    int n,k;
    int flag;
    scanf ("%d",&n);
    while(n--)
    {
        scanf("%d",&k);
        for(i=1;i<=k;i++)
            scanf("%d",&a[i]);
        for(i=2;i<=k;i++)
            scanf("%d",&b[i]);
        dp[0]=0;
        dp[1]=a[1];
        for(i=2;i<=k;i++)
            dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
             s=dp[k]%60;
             m=dp[k]/60;
             h=8+m/60;
             m%=60;
             h%=24;
             flag=0;
             if(h>=12)
             {
                 flag=1;
                 h-=12;
             }
             printf("%02d:%02d:%02d",h,m,s);
             if(flag)
                printf(" pm\n");
             else
                printf(" am\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值