HDU 1260 Tickets dp

Tickets


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4773    Accepted Submission(s): 2477




Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 


Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 


Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 


Sample Input
2
2
20 25
40
1
8
 


Sample Output
08:00:40 am
08:00:08 am
 


Source
浙江工业大学第四届大学生程序设计竞赛
 


Recommend
JGShining
 

优化之后,只剩两种状态,一种是单独购买,另一种就是和前面的人一起买,得到两个状态转移方程.

dp[i][0]=min(dp[i-1][0],dp[i-1][1])+s[i](单独购买)

dp[i][1]=min(dp[i-2][0],dp[i-2][1])+d[i];(和前面的人一起买)

ac代码

#include <cstdio>
#include <cmath>
#include <cstring>
#include <stack>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;

int n,k,s[2005],d[2005];
int dp[2005][2];
int main(){
	
	
	scanf("%d",&n);
	while(n--){
		scanf("%d",&k);
		for(int i=1;i<=k;i++){
			scanf("%d",&s[i]);
		}
		for(int i=2;i<=k;i++){
			scanf("%d",&d[i]);
		}
		d[1]=s[1];
		memset(dp,0,sizeof(dp));
		//dp[0][0]=dp[0][1]=0;
		for(int i=1;i<=k;i++){
			dp[i][0]=min(dp[i-1][0],dp[i-1][1])+s[i];
			if(i > 1){
				dp[i][1]=min(dp[i-2][0],dp[i-2][1])+d[i];
			}
			else
				dp[i][1]=s[i];
		}
		int ans=min(dp[k][0],dp[k][1]);
		int h=ans/3600;
		ans%=3600;
		int m=ans/60;
		ans%=60;
		int miao=ans;
		if(8 + h > 12){
			h=(8+h)%12;
			printf("%02d:%02d:%02d pm\n",h,m,miao);
		}
		else{
			//h=(8+h)%12;
			printf("%02d:%02d:%02d am\n",8+h,m,miao);
		}
	}
	
	
	return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值