Co-prime
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1111 Accepted Submission(s): 405
Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10
15) and (1 <=N <= 10
9).
Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
Sample Input
2 1 10 2 3 15 5
Sample Output
Case #1: 5 Case #2: 10HintIn the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
Source
不过可以简单转化一下,题目就是求[1, b]中互素的个数减去[1, a-1]中互素的个数。此时我们可以使用容斥原理。
即[1, b]中与2互为约数的数共有b/2个,与3互为约数的数的个数有b/3个。同时与2,3互为约数的数的个数就是b/2+b/3-b/lcm(2,3)。
把n因式分解分解。简单计算可以知道,前10个素数相乘大于6*10^10,n的范围是10^9,也就是说n的素数因子不超过10个。那么复杂度就不会超过2^10*10。完全可以接受。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
int prime[30];
int top;
int cas;
LL co_prime(LL val)
{
LL ans = 0;
for (int i = 1; i < (1 << top); i++)
{
LL tmp = 1, flag = 0;
for (int j = 0; j < top; j++) if (i&(1 << j))
tmp *= prime[j], flag++;
if (flag & 1)
ans += val / tmp;
else
ans -= val / tmp;
}
return val - ans;
}
void work()
{
LL a, b;
int n;
scanf("%I64d%I64d%d", &a, &b, &n);
top = 0;
for (int i = 2; i*i <= n; i++) if (n%i==0)
{
prime[top++] = i;
while (n%i == 0) n /= i;
}
if (n > 1)
prime[top++] = n;
printf("Case #%d: %I64d\n", ++cas, co_prime(b) - co_prime(a-1));
}
int main()
{
int T;
scanf("%d", &T);
while (T--)
work();
}