POJ 2992 Divisors 解题报告(素因子统计)

96 篇文章 0 订阅

Divisors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9978 Accepted: 2933

Description

Your task in this problem is to determine the number of divisors of  Cnk. Just for fun -- or do you need any special reason for such a useful computation?

Input

The input consists of several instances. Each instance consists of a single line containing two integers n and k (0 ≤ k ≤ n ≤ 431), separated by a single space.

Output

For each instance, output a line containing exactly one integer -- the number of distinct divisors of  Cnk. For the input instances, this number does not exceed 2 63 - 1.

Sample Input

5 1
6 3
10 4

Sample Output

2
6
16

Source


    解题报告:将素数打表,统计区间内的素因子数量,加1乘起来就是最终结果了。代码如下:

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <map>
#include <cstring>
using namespace std;

typedef long long LL;
const int maxn = 431+1;

bool h[maxn];
int prime[maxn];
int primeNum;

void calPrime()
{
    for(int i=2;i<maxn;i++) if(!h[i])
    {
        prime[primeNum++]=i;
        for(int j=i+i;j<maxn;j+=i) h[j]=true;
    }
}

int calN(int n, int t)
{
    int res=0;
    while(n>=t)
    {
        n/=t;
        res+=n;
    }
    return res;
}

LL ans[maxn][maxn];
void work(int n, int k)
{
    if(ans[n][k])
    {
        printf("%lld\n", ans[n][k]);
        return;
    }

    LL res=1;
    for(int i=0;i<primeNum && n>=prime[i];i++)
    {
        int t=calN(n, prime[i])-calN(k, prime[i])-calN(n-k, prime[i]);
        res = res*(t+1);
    }

    ans[n][k]=ans[n][n-k]=res;
    printf("%lld\n", res);
}

int main()
{
    calPrime();

    int n, k;
    while(~scanf("%d%d", &n, &k))
        work(n, k);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值