ACM--约数--HDOJ 1492--The number of divisors(约数) about Humble Numbers


HDOJ题目地址:传送门

The number of divisors(约数) about Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3331    Accepted Submission(s): 1630


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

 

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.
 

Output
For each test case, output its divisor number, one line per case.
 

Sample Input
  
  
4 12 0
 

Sample Output
  
  
3 6


题意:给出一个只包含质因数2,3,5,7的数,求其约数的个数
思路:如果n=p1^n1*p2^n2*...*pn^nn,其中p1,p2,...,pn表示质因数,n1,n2,...,nn表示相应质因数的指数,根据乘法原理,则约数的个数为(n1+1)(n2+1)...(nn+1)

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main(){
   __int64 n,a,b,c,d;
   while(scanf("%I64d",&n)&&n){
      a=1;b=1;c=1;d=1;
      while(n!=1&&n%2==0){
         a++;
         n/=2;
      }
      while(n!=1&&n%3==0){
         b++;
         n/=3;
      }
      while(n!=1&&n%5==0){
         c++;
         n/=5;
      }
      while(n!=1&&n%7==0){
         d++;
         n/=7;
      }
      printf("%I64d\n",a*b*c*d);
   }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值