POJ 2142 The Balance 解题报告(模线性方程)

96 篇文章 0 订阅
6 篇文章 0 订阅
The Balance
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 3794 Accepted: 1672

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

    解题报告: 由题意可列方程 ax+by=c。解该方程且使|x|+|y|尽量小,a*|x|+b*|y|尽量小。
    我们求解最小的正的x,求出相应的y,|x|+|y|以及a*|x|+b*|y|。交换a,b,用相同的方法求解,取较小的解即可。可以证明没有更好的解了。代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

typedef long long LL;

void exgcd(LL a, LL b, LL &d, LL &x, LL &y)
{
    if(b==0)
        d=a, x=1, y=0;
    else
        exgcd(b, a%b, d, y, x), y-=x*(a/b);
}

inline LL absLL(LL a)
{
    return a<0?-a:a;
}

struct Node
{
    LL x, y;
    LL sum, tol;

    bool operator<(const Node& cmp) const
    {
        if(sum==cmp.sum)
            return tol<cmp.tol;
        return sum<cmp.sum;
    }
} node[10];
int top;

LL linear_mod(LL a,LL b,LL c)
{
    LL x,y,d;
    exgcd(a,b,d,x,y);

    a/=d;
    b/=d;
    c/=d;

    x = (x*c%b+b)%b;
    node[top].x = x;
    node[top].y = absLL((c-a*x)/b);
    node[top].sum = node[top].x+node[top].y;
    node[top].tol = absLL(a*node[top].x*d)+absLL(b*node[top].y*d);
    top++;
}

int main()
{
    LL a, b, c, k;
    while(~scanf("%lld%lld%lld", &a, &b, &c) && (a||b||c))
    {
        top=0;
        linear_mod(a, b, c);
        linear_mod(b, a, c);
        swap(node[1].x, node[1].y);
        sort(node, node+top);
        printf("%lld %lld\n", node[0].x, node[0].y);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值