HDOJ P1253 胜利大逃亡 BFS+简单剪枝

博客讲述了在解决HDOJ P1253问题中遇到的超时(TLE)问题,通过引入BFS(宽度优先搜索)算法和简单的剪枝策略解决了问题。剪枝条件为:剩余时间不足以走出迷宫。作者还分享了AC(Accepted)代码,并对比了C++和C语言的运行效率,指出即使是优化后的cin在效率上仍不敌scanf。
摘要由CSDN通过智能技术生成

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22502    Accepted Submission(s): 8758


Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
  
  
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
  
  
11
 

Author
Ignatius.L
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1372  1242  1072  1240  1010 
 

之前在POJ上做过一道相似的题目 http://blog.csdn.net/kdwycz/article/details/8843835

提交后发现TLE,以为是cin的问题,反复修改还是TLE,最后google发现需要剪枝(为什么自己没想到啊啊啊啊)。简单思想就是当剩余时间没无论如何(即使没有一面墙)也走不出迷宫的话就结束搜索。公式为:a+b+c-temp.x-temp.y-temp.z<= t-temp.step

AC后改用G++提交,1450MS。C语言的话500MS,即使是优化后的cin效率还是不及scanf

上代码:

#include <iostream>
using namespace std;
 
const int dx[6] = { -1, 1, 0, 0, 0, 0 },
		  dy[6] = { 0, 0, -1, 1, 0, 0 },
		  dz[6] = { 0, 0, 0, 0, -1, 1 },
		  
		  maxm = 50, maxn = 125000;

struct point{
	int x, y, z, step;
}queue[maxn];

int n, a, b, c, t, map[maxm][maxm][maxm];

int check(point, int);
int bfs();
int main()
{
	ios::sync_with_stdio(false);
	cin>>n;
	while (n--){
		cin>>a>>b>>c>>t;
		for (int i = 0; i<a; ++i)
			for (int j = 0; j<b; ++j)
				for (int k = 0; k<c; ++k)
					cin>>map[i][j][k];
		cout<<bfs()<<endl;
	}
	return 0;
}

int bfs(){
	int fa = 0, so = 0, i;
	point temp;
	queue[0].x = 0; queue[0].y = 0;
	queue[0].z = 0; queue[0].step = 0;
	while (fa <= so && so<maxn && queue[fa].step<t){
		for (i = 0; i<6; ++i){
			temp.x = queue[fa].x + dx[i];
			temp.y = queue[fa].y + dy[i];
			temp.z = queue[fa].z + dz[i];
			temp.step = queue[fa].step + 1;
			if (check(temp, so)){
				if (temp.x == (a - 1) && temp.y == (b - 1) && temp.z == (c - 1))
					return temp.step;
				queue[++so] = temp;
			}
		}
		++fa;
	}
	return -1;
}

int check(point temp, int so){
	int x=a+b+c-temp.x-temp.y-temp.z;
	int y=t-temp.step;
	if (temp.x >= 0 && temp.x<a && temp.y >= 0 && temp.y<b && temp.z >= 0 && temp.z<c && map[temp.x][temp.y][temp.z]==0 && y>=x)
		for (int i = 0; i <= so; ++i){
			if (temp.x == queue[i].x && temp.y == queue[i].y && temp.z == queue[i].z)
				return 0;
		}
	else
		return 0;
	return 1;
}
最近好懈怠啊,加紧刷题!



kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz





kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值