Blue Jeans
Description
The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.
As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences. Input
Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
Output
For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.
Sample Input 3 2 GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA 3 GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA 3 CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT Sample Output no significant commonalities AGATAC CATCATCAT Source |
对于每组数据,寻找最长的公共子序列(大于3)。
枚举第一个字符串的子序列,对后面的串进行匹配。
听说不用kmp也能做
//其实这道题几天前就搞定了,只是写错了一个数组名,一直调试不过,今天才发现 ⊙﹏⊙b
#include <iostream>
using namespace std;
string s[10],temp,ans;
int n,m,i,j,i1,j1,l,p[60],flag;
int kmp(int x){
int j=-1;
for (int i=0;i<s[x].size();++i){
while (j>-1 && s[x][i]!=temp[j+1]) j=p[j];
if (s[x][i]==temp[j+1]) j++;
if (j+1==l) return 1;
}
return 0;
}
int main()
{
cin>>n;
while (n--){
cin>>m; ans=" ";
for (i=0;i<m;++i)
cin>>s[i];
for (i=0;i<58;++i)
for (j=3;j<61-i;++j){
temp=s[0].substr(i,j);
l=temp.size();
j1=-1; p[0]=-1;
for (i1=1;i1<l;++i1){
while (j1>-1 && temp[i1]!=temp[j1+1]) j1=p[j1];
if (temp[i1]==temp[j1+1]) j1++;
p[i1]=j1;
}
flag=true;
for (i1=1;i1<m && flag;++i1)
if (!kmp(i1))
flag=false;
if (flag)
if (l>ans.size() || (l==ans.size() && temp<ans))
ans=temp;
}
if (ans==" ")
cout<<"no significant commonalities\n";
else cout<<ans<<endl;
}
return 0;
}
kdwycz的网站: http://kdwycz.com/
kdwyz的刷题空间:http://blog.csdn.net/kdwycz