POJ 2785 4 Values whose Sum is 0 hash

4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 14198 Accepted: 4027
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source


和HDOJ 1496 Equations hash 方法完全一样。不过网上很多人的解法。开的hash表比我的小很多。。。不知道为什么。话说4000个数与4000个数 两两相加不是最多有4000*4000钟可能么。。。


还有一种二分查找的做法,效率不如hash

#include <iostream>
using namespace std;
const int MAX=4000*4000+1;
int h[MAX]={0},t[MAX]={0};
int n,i,j,a[4000],b[4000],c[4000],d[4000],p,sum=0;

int hash(int x){
	int y=x%MAX;
	if (y<0) y+=MAX;
	while (h[y]!=0&&t[y]!=x)
		y=(y+1)%MAX;
	return y;
}

int main()
{
	cin>>n;
	for (i=0;i<n;++i)
		cin>>a[i]>>b[i]>>c[i]>>d[i];
	for (i=0;i<n;++i)
		for (j=0;j<n;++j){
			p=hash(a[i]+b[j]);
			h[p]++;
			t[p]=a[i]+b[j];
		}
	for (i=0;i<n;++i)
		for (j=0;j<n;++j){
			p=hash(-c[i]-d[j]);
			sum+=h[p];
		}
	cout<<sum<<endl;
	return 0;
}

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值