POJ 1012 Joseph 约瑟夫问题

Joseph
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45959 Accepted: 17342

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

Source


普通的模拟过程会超时,需要计算n个人的环,每报m个数出列的人序号的公式。n个人分别编号0……(n-1)

第一个出列的人的序号f1=(m-1)%n

第二个出列的人的序号f1=(f1+m-1)%(n-1)

第i个出列的人的序号fi=((fi-1)+m-1)%(n-i+1)


然后就没什么问题了。。。

#include <iostream>
using namespace std;
int ans[15]={0},x,n,f[15]={0};

int joseph(int x){
	int m=x,i;
	while (m++){
		for (i=1;i<=x;++i){
			f[i]=(f[i-1]+m-1)%(n-i+1);
			if (f[i]<x) break;
		}
		if (i>x){
			ans[x]=m;
			return m;
		} 	
	}
}

int main()
{
	while (cin>>x && x){
		if (ans[x]) cout<<ans[x]<<endl;
		else{
			n=x*2;
			cout<<joseph(x)<<endl;
		}
	}
	return 0;
}

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值