POJ 2538 WERTYU 模拟

WERTYU
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8025 Accepted: 3832

Description

 
A common typing error is to place the hands on the keyboard one row to the right of the correct position. So "Q" is typed as "W" and "J" is typed as "K" and so on. You are to decode a message typed in this manner.

Input

Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input.

Output

You are to replace each letter or punctuation symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output. 

Sample Input

O S, GOMR YPFSU/

Sample Output

I AM FINE TODAY.

Source


#include <iostream>
using namespace std;
int main()
{
	char arr[128]; int i; string s;
	for (i=1;i<128;++i)
		arr[i]=i;
	arr['1']='`'; arr['W']='Q'; arr['S']='A'; arr['X']='Z';
	arr['2']='1'; arr['E']='W'; arr['D']='S'; arr['C']='X';
	arr['3']='2'; arr['R']='E'; arr['F']='D'; arr['V']='C';
	arr['4']='3'; arr['T']='R'; arr['G']='F'; arr['B']='V';
	arr['5']='4'; arr['Y']='T'; arr['H']='G'; arr['N']='B';
	arr['6']='5'; arr['U']='Y'; arr['J']='H'; arr['M']='N';
	arr['7']='6'; arr['I']='U'; arr['K']='J'; arr[',']='M';
	arr['8']='7'; arr['O']='I'; arr['L']='K'; arr['.']=',';
	arr['9']='8'; arr['P']='O'; arr[';']='L'; arr['/']='.';
	arr['0']='9'; arr['[']='P'; arr['\'']=';';
	arr['-']='0'; arr[']']='[';
	arr['=']='-';
	
	while (getline(cin,s)){
		for (i=0;i<s.size();++i)
			cout<<arr[s[i]];
		cout<<endl;
	}
	
	return 0;
}

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值