POJ 2612 Mine Sweeper 模拟

Mine Sweeper
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6234 Accepted: 2446

Description

The game Minesweeper is played on an n by n grid. In this grid are hidden m mines, each at a distinct grid location. The player repeatedly touches grid positions. If a position with a mine is touched, the mine explodes and the player loses. If a positon not containing a mine is touched, an integer between 0 and 8 appears denoting the number of adjacent or diagonally adjacent grid positions that contain a mine. A sequence of moves in a partially played game is illustrated below. 
 
Here, n is 8, m is 10, blank squares represent the integer 0, raised squares represent unplayed positions, and the figures resembling asterisks represent mines. The leftmost image represents the partially played game. From the first image to the second, the player has played two moves, each time choosing a safe grid position. From the second image to the third, the player is not so lucky; he chooses a position with a mine and therefore loses. The player wins if he continues to make safe moves until only m unplayed positions remain; these must necessarily contain the mines. 

Your job is to read the information for a partially played game and to print the corresponding board. 

Input

The first line of input contains a single postitive integer n <= 10. The next n lines represent the positions of the mines. Each line represents the contents of a row using n characters: a period indicates an unmined positon while an asterisk indicates a mined position. The next n lines are each n characters long: touched positions are denoted by an x, and untouched positions by a period. The sample input corresponds to the middle figure above.

Output

Your output should represent the board, with each position filled in appropriately. Positions that have been touched and do not contain a mine should contain an integer between 0 and 8. If a mine has been touched, all positions with a mine should contain an asterisk. All other positions should contain a period.

Sample Input

8
...**..*
......*.
....*...
........
........
.....*..
...**.*.
.....*..
xxx.....
xxxx....
xxxx....
xxxxx...
xxxxx...
xxxxx...
xxx.....
xxxxx...

Sample Output

001.....
0013....
0001....
00011...
00001...
00123...
001.....
00123...

Source


注意一点,如果点开了地雷,所有地雷都要输出 * 类比平时玩扫雷 o(╯□╰)o

#include <iostream>
using namespace std;

string a[12],b[12],s="............";
char c; 

int make(int x,int y){
	int i,j,ans=0;
	for (i=x-1;i<=x+1;++i)
		for (j=y-1;j<=y+1;++j)
			if (a[i][j]=='*')
				ans++;
	return ans;
}

int main()
{
	int n,i,j;
	cin>>n; c='.';
	for (i=1;i<=n;++i){
		cin>>a[i];
		a[i]='.'+a[i]+'.';
	}
	for (i=1;i<=n;++i){
		cin>>b[i];
		b[i]='.'+b[i]+'.';
		for (j=1;j<=n;++j)
			if (a[i][j]=='*' && b[i][j]=='x')
				c='*';
	}
	a[n+1]=b[n+1]=s;
		
	for (i=1;i<=n;++i,cout<<endl)
		for (j=1;j<=n;++j)
			if (a[i][j]=='*')
				cout<<c;
			else if (b[i][j]=='x')
				cout<<make(i,j);
			else
				cout<<'.';
	return 0;
} 

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值