HDOJ 1160 FatMouse's Speed


FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6269    Accepted Submission(s): 2730
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
  
  
4 4 5 9 7
 

Source
 

Recommend
Ignatius
 

最长下降子序列的变形。要输出序列序号。
先以weight为关键字排序,保存原序号(输出用)。再求最长下降子序列。
话说这道题我调试时为什么没法设置断点。。。。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
struct mouse{
	int weight,speed,ii;
}; 
int cmp(mouse,mouse); 
mouse a[1100];
int n,i,j,maxn,maxm,k,b[1100],c[1000];
int main(int argc, char *argv[])
{
	memset(c,0,sizeof(c)); i=1;
	while (cin>>a[i].weight>>a[i].speed){
		a[i].ii=i;
		++i;
		b[i]=1;
	} 
	n=i-1;
	sort(a+1,a+i,cmp);
//for (i=1;i<=n;++i)cout<<a[i].weight<<" "<<a[i].speed<<" "<<a[i].ii<<endl;
	for (i=n-1;i;--i)
		for (j=i+1;j<=n;++j)
			if ((a[j].speed<a[i].speed)&&(b[i]<b[j]+1)&&(a[i].weight!=a[j].weight)){
				b[i]=b[j]+1; c[i]=j;
			} 			
	for (i=1;i<=n;++i)
		if (maxn<b[i]){
			maxn=b[i];
			maxm=i;
		} 
	cout<<maxn<<endl<<a[maxm].ii<<endl;
	while (c[maxm]){
		cout<<a[c[maxm]].ii<<endl;
		maxm=c[maxm];
	}
	return 0;
}

int cmp(mouse a,mouse b){
	return a.weight<b.weight;
}

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值