POJ P2488 A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24019 Accepted: 8114

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

问题大意是输入n个棋盘大小。求一个骑士从A1不重复的把所有棋盘上的点都遍历一遍的路径并输出(字典序) 如果没有就输出impossible 

简单搜索,字典序是最大难点。


我WA一次因为没写 

Scenario #1:

真心无语。。。。。


#include <iostream>
#include <cstring>
using namespace std;

int dir[8][2]={-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2};
// -1, 1,-2, 2,-2, 2,-1, 1  本题最大难点 
// -2,-2,-1,-1, 1, 1, 2, 2  字典序 

string s;
int graph[10][10],out[100][2],n,m,a,b,flag,i;

void dfs(int,int,int);
void print();

int main()
{
	cin>>n;
	for (i=0;i<n;++i){
		cin>>a>>b;
		m=a*b; flag=0;
		memset(graph,0,sizeof(graph));
		memset(out,0,sizeof(out));
		graph[1][1]=1; out[1][0]=1; out[1][1]=1; 
		dfs(1,1,1);
		if (!flag){
			cout<<"Scenario #"<<i+1<<":\n";
			cout<<"impossible\n\n";
		} 
	}
	return 0;
}

void print(){
	flag=1;
	int j=1;
	char a;
	cout<<"Scenario #"<<i+1<<":\n";
	while (out[j][0]!=0){
		a='A'+out[j][1]-1;
		cout<<a<<out[j][0]; 
		j++;
	}
	cout<<endl<<endl;
	return;
}

void dfs(int ii,int ix,int iy){
	if (flag) return;
	if (ii==m) print();
	else{
		for (int i=0;i<=7;++i)
			if (ix+dir[i][0]>0 && ix+dir[i][0]<=a && iy+dir[i][1]>0 && 
			iy+dir[i][1]<=b && !graph[ix+dir[i][0]][iy+dir[i][1]]){
				graph[ix+dir[i][0]][iy+dir[i][1]]=1;
				out[ii+1][0]=ix+dir[i][0];
				out[ii+1][1]=iy+dir[i][1];
				dfs(ii+1,ix+dir[i][0],iy+dir[i][1]);
				graph[ix+dir[i][0]][iy+dir[i][1]]=0;
				out[ii+1][0]=0;
				out[ii+1][1]=0;
			}
	}
	return; 
}


kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值