hdu 5752 Sqrt Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 5    Accepted Submission(s): 5


Problem Description
Let's define the function .

Bo wanted to know the minimum number which satisfies .

note:

It is a pity that Bo can only use 1 unit of time to calculate this function each time.

And Bo is impatient, he cannot stand waiting for longer than 5 units of time.

So Bo wants to know if he can solve this problem in 5 units of time.
 

Input
This problem has multi test cases(no more than ).

Each test case contains a non-negative integer .
 

Output
For each test case print a integer - the answer or a string "TAT" - Bo can't solve this problem.
 

Sample Input
233233333333333333333333333333333333333333333333333333333333
 

Sample Output
3  TAT

一开始我也没发现规律...还以为要用高精度平方来做,但实际上是思维题,因为我们只需要找到开五次方等于1最大的数就可以了,sqrt2=1,sqrt3=1,sqrt4=2,sqrt15=2,sqrt16=3,所以sqrt(2^32)=6,而sqrt(2^32-1)=5,这恰好就是它的最大的数,因此,只需要判断给出的n是否大于等于sqrt(2^32)就可以了,如果大于等于,那么直接输出TAT,如果不是,那么还需要判断n!=0,因为sqrt(0)!=1,然后直接对n操作就可以了

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
int a[5009];
long long num=4294967296-1;
int main()
{
    char s[109];
    long long n,i;
    while(~scanf("%s",s))
    {
        n=strlen(s);
        if(n>10||s[0]=='0')
        {
            printf("TAT\n");
        }
        else
        {
            long long sum=0;
            int count=0;
            for(i=0;i<=n-1;i++)
            {
                sum=sum*10+s[i]-'0';
            }
            if(sum>num)
            {
                printf("TAT\n");
                continue;
            }
            while(sum!=1)
            {
                sum=(long long )sqrt(sum);
                count++;
            }
            printf("%d\n",count);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值