17111 Football team(暴力)

17111 Football team

时间限制:1000MS  内存限制:65535K
提交次数:0 通过次数:0

题型: 编程题   语言: G++;GCC

Description

As every one known, a football team has 11 players . Now, there is a big problem in front of the Coach Liu. The final contest is getting closer. 
Who is the center defense, the full back or the forward? ...... There are n wonderful players for n positions in the team and Coach Liu know 
everyone's abilities at different positions in matches. Assume that the team's power is the sum of the abilities of all n players according to 
their positions, could you help Coach Liu to find out the max power his team can get?



输入格式

The first line is an integer n(n<11). Followed by n rows. Each row has n integer (0 to 1000) which represents the abilities of one player 
at different positions.


输出格式

The max power.


输入样例

10
4 6 3 3 4 5 7 4 9 0
5 9 3 4 6 1 7 3 9 3
1 5 8 0 5 4 2 7 9 3
4 6 9 4 7 3 7 9 5 4
2 0 1 3 2 5 8 4 6 2
1 5 8 4 2 6 8 0 4 2
1 4 2 6 8 9 4 2 6 8
1 2 9 5 6 4 2 7 5 7
2 4 7 5 8 5 3 2 6 4
2 4 6 4 8 7 3 5 7 3


输出样例

76


作者

admin

暴力求解就可以了,题目意思就是一个人每一列只能选一次,那么用个vis数组去标记是否被选过,如果被选过就跳过,没有被选过就选择,进入下一层递归,递归回来后要清除标记

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string.h>
using namespace std;
int vis[100];
int map[109][109];
int M;
int A;
int n;
void dfs(int step,int sum)//step为第几行
{
    int i;
    if(step==n+1)
    {
        M=max(M,sum);
        return ;
    }
    for(i=1;i<=n;i++)//单纯n次无任何意义
    {
        if(!vis[i])
        {
            vis[i]=1;
            dfs(step+1,sum+map[step][i]);
            vis[i]=0;
        }
    }
}
int main()
{
    int i,j;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
        {
            scanf("%d",&map[i][j]);
        }
    }
    M=0;
    memset(vis,0,sizeof(vis));
    dfs(1,0);
    printf("%d\n",M);
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值