1503. Integer Inquiry

Description

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
This supercomputer is great,'' remarked Chip.I only wish Timothy were here to see these results.” (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
Output

Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
Sample Output

370370367037037036703703703670


思路

这道题比较简单,单独考虑每一位的相加,处理一下进位就ok了!
注意:

  1. 求和的sum数组大小至少sum[102];
  2. 题目中有no VeryLongInteger will be negative 这样的描述,所以输入中可能有以0开头的数,判断输入结束应该使用strcmp(a,”0”)语句,而非a[0]!=0;

代码

#include <iostream>
#include <string.h>

using namespace std;

int main()
{
    char a[101];
    int sum[102] = { 0 };
    int i = 0,j = 0;

    cin >> a;
    while (strcmp(a,"0"))
    {
        for (i = 0; i < strlen(a); i++)
        {
            sum[i] += a[strlen(a) - i - 1] - '0';
            if (sum[i] >= 10)   //进位的处理
            {
                sum[i] -= 10;
                sum[i + 1] += 1;
                j = i + 1;
            }
            else {
                j = i;
            }   
        }
        cin >> a;
    }

    for (i = j; i >= 0; i--)  //将sum逆序输出
    {
        cout << sum[i];
    }

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值