POJ 3694 Network

Network
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 9353 Accepted: 3479

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2

0

题意:给出一幅无向图(保证都连通),然后每次给图加上1条边,询问加上该边后图中割边的数目

我的做法是首先边双连通+并查集缩点(貌似数据并没有重边),把同一个边双联通得点并成同一个集合,

而且统计出割边数;然后每次加边后找到边两端连通块的最小公共祖先,而后把这两个连通块与及一直向前到 最近公共祖先(LCA)之间的所有不同的连通块(包括最近公共祖先)并成同一个边双连通(用并查集),期间割边的减少

与连通块的减少数目相同。具体情况看代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <stack>
using namespace std;
const int maxn = 1e5 + 7;
int pre[maxn], low[maxn], _clock, bridge;
int ancestor[maxn], vis[maxn];
vector<int> edge[maxn];

void init(int n){ /// 初始化
    for(int i = 1; i <= n; i ++){
        edge[i].clear();
        vis[i] = i;
    }
    memset( pre, 0, sizeof( pre));
    memset( low, 0, sizeof( low));
    bridge = _clock = 0;
}

int Find_set(int key){ /// 查找个节点并压缩路径
    if(key != vis[key]) vis[key] = Find_set(vis[key]);
    return vis[key];
}

void Union(int a, int b){ /// 
    int p = Find_set(a);
    int q = Find_set(b);
    if(p != q) vis[p] = q;
}

void DFS(int st, int fa){ /// Tarjan算法找边双联通
    pre[st] = low[st] = ++ _clock;
    int tt = edge[st].size(), x;
    for(int i = 0; i < tt; i ++){
        x = edge[st][i];
        if(x == fa) continue;
        if(!pre[x]){
            ancestor[x] = st;
            DFS(x, st);
            low[st] = min(low[st], low[x]);
            if(low[x] > pre[st]) bridge ++;  // 割边
            else Union(x, st);
        }
        else low[st] = min(low[st], pre[x]);
    }
}

int LCA(int l, int r){ /// 最近公共祖先
    if(Find_set(l) == Find_set(r)) return bridge;
    if(pre[l] > pre[r]) swap(l, r);
    while(pre[l] < pre[r]){  // 找到时间戳刚好比 l 大的连通块,这就是 l 与 r 的最近公共祖先,不明白可以自行模拟一下
        if(vis[ancestor[r]] != vis[r]){ // 判断r与人
            Union(r, ancestor[r]);
            bridge --;
        }
        r = vis[r];
    }
    while(l != r){ /// 往前找,直到找到 r 所在的连通块
        if(vis[ancestor[l]] != vis[l]){ 
            Union(l, ancestor[l]);
            bridge --;
        }
        l = vis[l];
    }
    return bridge;
}

int main(){
    int n, m, k, x, y, u = 0;
    while(~scanf("%d %d", &n, &m)){
        if(!n && !m) break;
        init(n);
        for(int i = 1; i <= m; i ++){
            scanf("%d %d", &x, &y);
            edge[x].push_back(y);
            edge[y].push_back(x);
        }
        DFS(1, -1);
        scanf("%d", &k);
        printf("Case %d:\n", ++ u);
        for(int i = 1; i <= k; i ++){
            scanf("%d %d", &x, &y);
            printf("%d\n", LCA(x, y));
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值