POJ3694 Network

D - Network

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ AB ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ ABN), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

思路:

求每次添加边后剩余的桥的数量

AC历程:

固执如我,偏要用判重边,每次输入在tarjan一遍,就是WR;

终于WR的没脾气了,就用了LCA,一发A。。。。

AC代码: 

#include<math.h>
#include<queue>   //割桥
#include<stack>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1e5+7;
#define mem(a,b) memset(a,b,sizeof(a))

//low[]i及i的子孙相连的辈分最高的祖先节点所在的深度
//dfn[]i的深度
//tot树深,T_cou连通分量的个数
//in_stack[]是否在栈中
int dfn[maxn],low[maxn];
int tot,n,T_bridge;
int fi[maxn],len;
int fa[maxn];
bool bridge[maxn];
struct Adjcent
{
    int U,V;
    int ne;
}Adj[4*maxn];           ///
void add(int u,int v)
{
    Adj[len].U=u;
    Adj[len].V=v;
    Adj[len].ne=fi[u];
    fi[u]=len++;

    Adj[len].U=v;
    Adj[len].V=u;
    Adj[len].ne=fi[v];
    fi[v]=len++;
}
void init()
{
    mem(low,0);
    mem(dfn,0);
    mem(fi,-1);
    mem(fa,0);
    mem(bridge,0);
    T_bridge=tot=len=0;
}
void tarjan(int x,int y)
{
    dfn[x]=low[x]=++tot;
    for(int i=fi[x];i!=-1;i=Adj[i].ne)
    {
        int v=Adj[i].V;
        if(!dfn[v])
        {
            tarjan(v,x);
            fa[v]=x;        //存下父节点
            low[x]=min(low[x],low[v]);
            if(low[v]>dfn[x])
              {
                   T_bridge++;
                   bridge[v]=true;   //标记这条是桥
              }
        }
        else if(v!=y)
            low[x]=min(low[x],dfn[v]);
    }
}
int LCA(int u,int v)  //求u-->LCA<u,v>-->V中桥的数量
{
    if(u==v)
        return 0;
    int ans=0;
    while(u!=v)
    { 
        if(dfn[u]<dfn[v])   //找更深的点,向上爬
            swap(u,v);
        ans+=bridge[u];
        bridge[u]=false;   //消除桥的标记
        u=fa[u];           //向上爬
    }
    return ans;
}
int main()
{
    int m,u,v,cas=1,q;
    while(~scanf("%d%d",&n,&m)&&(n||m))
    {
        init();
        int flag;
        for(int i=0;i<m;i++)
        {
            scanf("%d %d",&u,&v);
            add(u,v);
        }
        tarjan(1,0);
        printf("Case %d:\n",cas++);
        scanf("%d",&q);
        for(int i=0;i<q;i++)
        {
            scanf("%d %d",&u,&v);
            T_bridge-=LCA(u,v);
            printf("%d\n",T_bridge);
        }
        puts("");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值