NYLG #17 (单调递增子序列)


链接:http://acm.nyist.net/JudgeOnline/problem.php?pid=17


描述
求一个字符串的最长递增子序列的长度
如:dabdbf最长递增子序列就是abdf,长度为4
输入
第一行一个整数0<n<20,表示有n个字符串要处理
随后的n行,每行有一个字符串,该字符串的长度不会超过10000
输出

输出字符串的最长递增子序列的长度
样例输入
3
aaa
ababc
abklmncdefg
样例输出
1
3
7


解题思路及方法:

两种方法,一种求最长公共子序列,一种求最长逆序, 求来求去还是最长公共子序列问题;

Method I:

#include <stdio.h>

#include <stdlib.h>
#include <string>
#include <iostream>
using namespace std;

int n, len1, len2 = 26;
int num[27][10001];
string ch1, ch2 = "abcdefghijklmnopqrstuvwxyz";

void Kesha()
{
    for(int i=0; i<len2; i++) {
        for(int j=0; j<len1; j++) {
            num[i+1][j+1] = 0;
            if(ch1[j] == ch2[i])
                num[i+1][j+1] = num[i][j] + 1;
            else {
                if(num[i][j+1] > num[i+1][j])
                    num[i+1][j+1] = num[i][j+1];
                else num[i+1][j+1] = num[i+1][j];
            }
        }
    }
}

int main()
{
    cin >> n;
    while(n--) {
        cin >> ch1;
        len1 = ch1.length();
        Kesha();
        cout << num[len2][len1] << endl;
    }
    return 0;
}
Method II:
#include<iostream>
#include <string>
#include <time.h>
using namespace std;

int main()
{
	//freopen("1.txt","r",stdin);
	int n ;
	cin >> n;
	while(n--) {
		string str;
		int count = 1;
		cin >> str;
		int a[200];
		a[0] = -999;
		for (int i=0; i<str.length(); i++) {
			for (int j=count-1; j>=0; j--) {
				if((int)str[i] > a[j]) {
					a[j+1] = str[i];
					if(j+1 == count) count++;
					break;
				}
			}
		}
		cout << count-1 << endl;
	}
	//cout<<(double)clock()/CLOCKS_PER_SEC<<endl;
	return 0;
}        




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值