fibonacci数列(二) nylg148

本文详细探讨了Fibonacci数列的第二部分,涵盖了矩阵相乘的优化方法及其在数学中的应用,适合对斐波那契数列感兴趣的读者深入学习。
摘要由CSDN通过智能技术生成

fibonacci数列(二)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

输入
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1
样例输出
0
34
6875

 

package hpu;

import java.util.Scanner;

public class Nylg148 {
	public static int n;
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while((n=sc.nextInt()) != -1){
			int[][] result = {{1, 0}, {0, 1}};
			int[][] a = {{1, 1}, {1, 0}};
			while(n != 0) {
				if((n&1) == 1) {
					matrix(result, a);//当前n的最后一位为1
				}
				matrix(a, a);
				n >>= 1; 
			}
			System.out.println(result[1][0]);
		}
	}

	private static void matrix(int[][] a1, int[][] a2) {
		int[][] c = new int[2][2];
		for(int i=0; i<2; i++) {
			for(int j=0; j<2; j++) {
				for(int k=0; k<2; k++) {
					c[i][j] = (c[i][j]+a1[i][k]*a2[k][j])%10000;
				}
			}
		}
		for(int i=0; i<2; i++) {
			for(int j=0; j<2; j++) {
				a1[i][j] = c[i][j];
			}
		}
	}

}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值