HDOJ-2717-Catch That Cow

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9647    Accepted Submission(s): 3016


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
 

题意:一维坐标上,人抓牛,牛在定点K,人在N,上线都是10w,人每步有三种走法,左移一格,右移一格,或者传送至当前坐标乘二,求最少几步找到牛.

bfs模板题,甚至只用一维即可,注意限定上边界

 

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
using namespace std;
#define INF 0x3f3f3f3f
int sx,ex,ans,vis[1000000];
int dx[3]={0,-1,1};//步(加一或减一)
int dy[3]={1,0,0};//传(加一倍)

struct node
{
	int x,step;
	friend bool operator < (node a,node b)
	{
		return a.step>b.step;
	}
}now,then;

bool juge(int x){
	if(x<0||x>110000||vis[x])//限定上界写x>2*ex不对,还可能倒着走 
		return false;
	return true;
}
void bfs()
{
	now.x=sx;
	now.step=0;
	memset(vis,0,sizeof(vis));
	priority_queue<node>q;
	vis[sx]=1;
	q.push(now);
	while(!q.empty())
	{
		now=q.top();
		q.pop();
		for(int v=0;v<3;v++){
			then.x=now.x+dx[v]+dy[v]*now.x;//为什么这么写带进去试试就知道了
			if(juge(then.x)){
				then.step=now.step+1;
				if(then.x==ex){
					ans=then.step;
					return;
				}
				vis[then.x]=1;
				q.push(then);
			}
		}
	}
}
int main()
{
	while(scanf("%d%d",&sx,&ex)!=EOF)
	{
		if(sx==ex)
		{
			printf("0\n");
			continue;
		}
		ans=INF;
		bfs();
		printf("%d\n",ans);
	}
}        



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值