Power of Cryptography |
Background
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
The Problem
Given an integer and an integer you are to write a program that determines , the positive root ofp. In this problem, given such integers n and p,p will always be of the form for an integerk (this integer is what your program must find).
The Input
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs , and there exists an integerk, such that .
The Output
For each integer pair n and p the value should be printed, i.e., the numberk such that .
Sample Input
2 16 3 27 7 4357186184021382204544
Sample Output
4 3 1234
题目大意&&思路:
求k;
思路:double水过
不过因为C语言基础不好,精度WA哭我了。囧。。
AC program:
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
double p,n;
while(cin>>n>>p)
{
double tmp=1.0/n;
cout<<(int)(pow(p,tmp)+0.5)<<endl;
}
//system("pause");
return 0;}
注意:用double输出整数的时候要四舍五入啊~~呜呜~~下面的printf就是可以四舍五入的写法或者上面+0.5的写法,如果不要求输出整数的时候,printf最好用f,因为lf是不规范的。请看链接:http://blog.csdn.net/kg_second/article/details/8042655
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
double p,n;
while(cin>>n>>p)
{
printf("%.0lf\n",pow(p,1.0/n));
}
//system("pause");
return 0;}