A very hard mathematic problem HDU - 4282

A very hard mathematic problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7411 Accepted Submission(s): 2232

Problem Description
  Haoren is very good at solving mathematic problems. Today he is working a problem like this:
  Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
   X^Z + Y^Z + XYZ = K
  where K is another given integer.
  Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
  Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
  Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
  Now, it’s your turn.

Input
  There are multiple test cases.
  For each case, there is only one integer K (0 < K < 2^31) in a line.
  K = 0 implies the end of input.
  

Output
  Output the total number of solutions in a line for each test case.

Sample Input

9
53
6
0

Sample Output

1
1
0
  
Hint

9 = 1^2 + 2^2 + 1 * 2 * 2
53 = 2^3 + 3^3 + 2 * 3 * 3

Source
2012 ACM/ICPC Asia Regional Tianjin Online

Recommend
liuyiding

1.枚举+快速幂

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define maxx 1e9
using namespace std;
typedef long long ll;
ll powmod(ll a, ll b)//快速幂
{
    ll ans = 1;
    while(b)
    {
        if(b%2==1)
            ans = (ans * a);
        b=b/2;
        a = (a*a);
    }
    return ans;
}
int main()
{
    int i,j;
    int k;
    int z;
    while(cin>>k, k)
    {
        int ans = 0;
        ll tx,ty;
        ll tk = (int)sqrt(k*1.0);
        if(tk*tk == k)
            ans += (tk-1)/2;
        for(z=3; z<31; z++)
        {
            for(ll x=1; ; x++)
            {
                ll tx = powmod(x,z);
                if(tx >= k/2) break;
                for(ll y=x+1; ; y++)
                {
                    ll ty = powmod(y, z);
                    if( tx + ty + x*y*z > k) break;
                    else if(tx + ty + x*y*z == k)
                    {
                        ans++;
                        break;
                    }
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

2.暴搜+二分

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define maxx 1e9
using namespace std;
typedef long long ll;
ll powmod(ll a, ll b)
{
    ll ans = 1;
    while(b)
    {
        if(b%2==1)
            ans = (ans * a);
        b=b/2;
        a = (a*a);
    }
    return ans;
}
int main()
{
    int i,j;
    int k;
    int z;
    while(cin>>k, k)
    {
        int ans = 0;
        ll tx,ty;
        ll lt,rt;
        ll tk = (int)sqrt(k*1.0);
        if(tk*tk == k)
            ans += (tk-1)/2;
        for(z=3; z<31; z++)
        {
            for(ll y=2; ;y++)
            {
                ty = powmod(y, z);
                if(ty > k) break;
                lt =1; rt=y-1;
                while(lt<=rt)
                {
                    ll x= (lt+rt)/2;
                    ll ta=pow(x, z) + pow(y, z) + x*y*z;
                    if(ta < k)
                    {
                        lt++;
                    }
                    else if(ta > k)
                    {
                        rt--;
                    }
                    else
                    {
                        ans++;
                        break;
                    }
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值