HDU 4282 A very hard mathematic problem

Description

  Haoren is very good at solving mathematic problems. Today he is working a problem like this: 
  Find three positive integers X, Y and Z (X < Y, Z > 1) that holds 
   X^Z + Y^Z + XYZ = K 
  where K is another given integer. 
  Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2. 
  Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions? 
  Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem. 
  Now, it’s your turn. 

Input

  There are multiple test cases. 
  For each case, there is only one integer K (0 < K < 2^31) in a line. 
  K = 0 implies the end of input.    

Output

  Output the total number of solutions in a line for each test case. 

Sample Input

9
53
6
0

Sample Output

1
1
0

Hint

       
       
9 = 1^2 + 2^2 + 1 * 2 * 2 53 = 2^3 + 3^3 + 2 * 3 * 3

这题就是利用暴力求解,为了防止超时,技巧有从z开始枚举,把需要枚举的次数较多的z=2的情况单独列出来,利用sqrt求解。还有要注意的是虽然题目中说k<2^31,但实际上我们求解时是会用到超出32位的情况的,如果还用int,就不行了,所以记得用__int64.

#include <stdio.h>
#include<math.h>

__int64 pow(__int64 a,__int64 n)
{
    __int64 ret=1;
    __int64 temp=a;
    while(n)
    {
        if(n&1)ret*=temp;
        temp*=temp;
        n>>=1;
    }
    return ret;
}

int main()
{
	__int64 k;
	while(~scanf("%I64d",&k)&&k)
	{
		__int64 x=1,y=2,z=2;
		__int64 ans=0;
		__int64 u,v;
		x=sqrt(k);
		if(x*x==k) ans+=(x-1)/2;
		for(z=3;z<31;z++)
		{
			for(x=1;;x++)
			{
                u=pow(x,z);
                if(u*2>=k)break;
                for( y=x+1;;y++)
                {
                    v=pow(y,z);
                    if(u+v+x*y*z>k)break;
                    if(u+v+x*y*z==k)
					{
						ans++;
						break;
					}
				}
			}
		}
		printf("%I64d\n",ans);
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值