AreYouBusy HDU - 3535 (DP 分组背包)

Happy New Term! 
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad. 
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)? 

Input

There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

Output

One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

Sample Input

3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10

Sample Output

5
13
-1
-1

 

思路:分组背包

有三种情况,

一、这个组 至少选一个,

二、这个组最多选一个

三、这个组随便选。

dp[i][j] 代表到 第i组,我容量是 j 的价值是多少。
当第一种情况的时候,我们可以推公式。  dp[i][j] = max(dp[i][j],max(dp[i][j-v]+w,dp[i-1][j-v] +w));
当第二种,第三种情况的时候,我们要整体复制一下,以为可以存在不选择的情况。 
当第二种情况的时候,我们可以退公式。  dp[i][j] = max(dp[i][j],dp[i-1][j-v]+w); 
当第三种情况的时候,我们可以推公式。  就是个 01 背包。

 

 

我一直wa 的原因是  v 可以是 0, 所以 dp[i][j-v] 要在前面。

 

#include<bits/stdc++.h>
using namespace std;
const int N = 200;
int dp[N][N],n,m,a[N],b[N];
int main(){
    while(~scanf("%d%d",&n,&m)){
        memset(dp,-1,sizeof dp);
        for (int i = 0; i <= m; ++i) dp[0][i] = 0;
        int x,y,s,t;
        for (int i = 1; i <= n; ++i){
            scanf("%d%d",&x,&y);
            if (y == 0){
                for (int j = 0; j < x; ++j){
                    scanf("%d%d",&s,&t);
                    for (int k = m; k >= s; --k){
                        
                        if (dp[i][k-s] != -1)
                            dp[i][k] = max(dp[i][k],dp[i][k-s]+t);
                         if (dp[i-1][k-s] != -1)
                            dp[i][k] = max(dp[i][k],dp[i-1][k-s]+t);
                    }
                }
            } else if (y == 1){
                for (int j = 0; j <= m; ++j) dp[i][j] = dp[i-1][j];
                for (int j= 0; j < x; ++j){
                    scanf("%d%d",&s,&t);
                    for (int k = m; k >= s; --k){
                        if (dp[i-1][k-s] != -1)
                            dp[i][k] = max(dp[i][k],dp[i-1][k-s]+t);
                    }
                }
            } else {
                for (int j = 0; j <= m; ++j) dp[i][j] = dp[i-1][j];
                for (int j = 0; j < x; ++j){
                    scanf("%d%d",&s,&t);
                    for (int k = m; k >= s; --k){
                        if (dp[i][k-s]  != -1)
                            dp[i][k] =max(dp[i][k],dp[i][k-s]+t);
                    }
                }
            }
        }
        printf("%d\n",dp[n][m]);
    }

    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值