师--链表的结点插入

师–链表的结点插入

Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description

给出一个只有头指针的链表和 n 次操作,每次操作为在链表的第 m 个元素后面插入一个新元素x。若m 大于链表的元素总数则将x放在链表的最后。
Input

多组输入。每组数据首先输入一个整数n(n∈[1,100]),代表有n次操作。
接下来的n行,每行有两个整数Mi(Mi∈[0,10000]),Xi。
Output

对于每组数据。从前到后输出链表的所有元素,两个元素之间用空格隔开。
Sample Input

4
1 1
1 2
0 3
100 4
Sample Output

3 1 2 4

#include <stdio.h>
#include <stdlib.h>

struct node {
    int data;
    struct node *next;
};

void create(int num,int data,struct node *head)
{
    struct node *p,*q,*tail;

    p=(struct node*)malloc(sizeof(struct node));
    p->next=NULL;
    p->data=data;

    q=head->next;
    tail=head;
    //是在tail后面,q前面插入。
    while(num--&&q)
    {
        q=q->next;
        tail=tail->next;
    }
    if(q)
    {
        tail->next=p;
        p->next=q;
    }
    else //表明,表明q==NULL,则tail就是属于最后一个元素。
    {
        tail->next=p;
        p->next=NULL;
    }
}
void show (struct node *head)
{
    head=head->next;
    while(head)
    {
        if(head->next==NULL)
            printf("%d\n",head->data);
        else
            printf("%d ",head->data);
        head=head->next;
    }
}
int main()
{
    int n,data,num;
    struct node *head;
    while(scanf("%d",&n)!=EOF)
    {
        head=(struct node*)malloc(sizeof(struct node));
        head->next=NULL;
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d",&num,&data);
            create(num,data,head);
        }
        show(head);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值