POJ 3621-- Sightseeing Cows

 Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 3621
Appoint description:

Description

Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time.

Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landmarks (conveniently numbered 1.. L) and the P (2 ≤ P ≤ 5000) unidirectional cow paths that join them. Farmer John will drive the cows to a starting landmark of their choice, from which they will walk along the cow paths to a series of other landmarks, ending back at their starting landmark where Farmer John will pick them up and take them back to the farm. Because space in the city is at a premium, the cow paths are very narrow and so travel along each cow path is only allowed in one fixed direction.

While the cows may spend as much time as they like in the city, they do tend to get bored easily. Visiting each new landmark is fun, but walking between them takes time. The cows know the exact fun values Fi (1 ≤ Fi ≤ 1000) for each landmark i.

The cows also know about the cowpaths. Cowpath i connects landmark L1i to L2i (in the direction L1i -> L2i ) and requires time Ti (1 ≤ Ti ≤ 1000) to traverse.

In order to have the best possible day off, the cows want to maximize the average fun value per unit time of their trip. Of course, the landmarks are only fun the first time they are visited; the cows may pass through the landmark more than once, but they do not perceive its fun value again. Furthermore, Farmer John is making the cows visit at least two landmarks, so that they get some exercise during their day off.

Help the cows find the maximum fun value per unit time that they can achieve.

Input

* Line 1: Two space-separated integers: L and P
* Lines 2..L+1: Line i+1 contains a single one integer: Fi
* Lines L+2..L+P+1: Line L+i+1 describes cow path i with three space-separated integers: L1i , L2i , and Ti

Output

* Line 1: A single number given to two decimal places (do not perform explicit rounding), the maximum possible average fun per unit time, or 0 if the cows cannot plan any trip at all in accordance with the above rules.

Sample Input

5 7
30
10
10
5
10
1 2 3
2 3 2
3 4 5
3 5 2
4 5 5
5 1 3
5 2 2

Sample Output

6.00


题目大意:一个人带牛去旅行,可以任意选定一个起点出发,然后最后要回到起点,是单向边,从一个地点走到另一个地点要消耗时间他,然后每个地点有一个欢乐值,并且一个地点走过了以后就不会在获得欢乐值,问你怎样走能使最后获得的欢乐值除以时间最大。

思路:二分枚举欢乐值得平均值,然后每个地点的欢乐值减去平均值乘以该边的时间t,因为如果存在正权环的话说明该环的所有欢乐值加起来大于平均值mid乘以该环中所用总时间的值,即mid这时小了,然后用spfa判断是否图中存在正权环,如果存在说明平均值mid小了 l= mid 否则 r = mid枚举100次就可以得到误差只有10负30次方的答案;



代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <cstdlib>
#include <cstring>
#include <algorithm>
//typedef __int64 LL;
using namespace std;
int vis[1100],head[1100],count1,cnt[1100],n,m;
double d[1100],val[1100];
struct Edge
{
    int u,v,next;
    double w,t;
    Edge(int a = 0, int b =0 ,double c = 0,double d = 0)
    {
        u = a; v =b; w= c; t = d;
    }
}e[5500];
void add(Edge q)
{
    e[count1].u = q.u;
    e[count1].v = q.v;
    e[count1].w = q.w;
    e[count1].t = q.t;
    e[count1].next = head[q.u];
    head[q.u] = count1++;
}
bool spfa(double mid)
{
    memset(vis,0,sizeof(vis));
    memset(d,0,sizeof(d));
    int i;
    memset(cnt,0,sizeof(cnt));
    int q[1100],tot = 0;
    for(i = 1; i<= n; i++)
    {
        q[tot++] = i;
        vis[i] = 1;
    }
    while (tot)
    {
        int w = q[--tot];
        vis[w] = 0;
        for(i = head[w]; i!=-1;i = e[i].next)
        {
            int end = e[i].v;
            if(d[end] < d[w] +e[i].w- mid * e[i].t)
            {
                d[end] = d[w] + e[i].w - mid*e[i].t;
                if(vis[end] == 0)
                {
                    vis[end] = 1;
                    q[tot++] = end;
                    cnt[end]++;
                    if(cnt[end] > n)
                        return true;
                }
            }
        }
    }
    return false;
}
int main()
{
    int i,a,b;
    double t;
    while (scanf("%d %d",&n,&m)!=EOF)
    {
        for(i = 1; i <= n ; i++)
        {
            scanf("%lf",&val[i]);
        }
        count1 = 0;
        memset(head,-1,sizeof(head));
        for(i = 0; i < m ; i++)
        {
            scanf("%d %d %lf",&a,&b,&t);
            add(Edge(a,b,val[b],t));
        }
        double l = 0, r = 1009;
        for(i = 0; i < 30; i++)
        {
              
            double mid = (r+ l)/2;
            if(spfa(mid)) l = mid;
            else r = mid;
        }
        if(l > 1000)
            cout<<"0"<<endl;
        else 
            printf("%.2lf\n",l);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值