1154 Vertex Coloring (25 分)

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

分析:题目大意是 给出一个图,并给出图中每个节点的颜色,要求是否满足所有边的两个点颜色不同。

1.vector<vector<int>>构造图;

2.建立set容器用于存储各个节点颜色以便统计不同颜色数目;

3.对图每个节点判断其与所连节点是否有共同颜色,若有则break,输出”No";

#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<cmath>
#include<unordered_map>
//1009;
using namespace std;
typedef long long ll;
const int inf = 99999999;
int n, m, k;
vector<vector<int>> vt; //构造图
vector<int> color; //存储节点颜色
set<int> st; //统计不同颜色节点
bool fun(int index) {
	st.insert(color[index]);
	for (int i = 0; i < vt[index].size(); i++) {
		if (color[vt[index][i]] == color[index]) { //判断两个节点颜色是否相同
			return false;
		}
	}
	return true;
}
int main() {
	cin >> n >> m;
	int a, b;
	vt.resize(n);
	for (int i = 0; i < m; i++) {
		cin >> a >> b;
		vt[a].push_back(b);
		vt[b].push_back(a);
	}
	cin >> k;
	color.resize(n);
	while (k--) {
		st.clear(); //每次测试需要clear
		for (int i = 0; i < n; i++) {
			cin >> color[i];
		}
		for (int i = 0; i < n; i++) {
			if (!fun(i)) { //判断该节点与所有相连节点颜色是否相同,若有相同则返回false
				st.clear(); 
				break;
			}
		}
		if (!st.size()) cout << "No" << endl;
		else cout << st.size() << "-coloring" << endl;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值