1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

分析:题目大意是顺序输入二叉树的每个节点所对应的左节点和右节点的下标,按照要求输出二叉树的镜像。

如图:

 

#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<cmath>
#include<unordered_map>
//1009;
using namespace std;
typedef long long ll;
const int inf = 99999999;
int n;
struct tree {
	int num;
	int left=-1;
	int right=-1;
}s[15];
bool parent[15]; //判断节点对应的父节点是否存在
void level(int root) {
	queue<int> q;
	q.push(root);
	int cnt = 0;
	while (!q.empty()) {
		int temp = q.front();
		if (cnt++) cout << " ";
		cout << temp;
		q.pop();
		if (s[temp].right != -1) q.push(s[temp].right); //逆置
		if (s[temp].left != -1) q.push(s[temp].left);
	}
	cout << endl;
}
bool flag = 0;
void inorder(int root) {
	if (root == -1) return;
	inorder(s[root].right); //逆置
	if (flag) cout << " ";
	cout << root;
	flag = 1;
	inorder(s[root].left);
}
int main() {
	cin >> n;
	char a, b;
	for (int i = 0; i < n; i++) {
		cin >> a >> b;
		if (a != '-') s[i].left = a - '0',parent[a-'0']=1; //下标a对应的父节点存在
		if (b != '-') s[i].right = b - '0',parent[b-'0']=1; //下标b对应的父节点存在
	}
	int root;
	for (int i = 0; i < n; i++) {
		if (!parent[i]) {
			root = i; //root为根节点
			break;
		}
	}
	level(root); //层序遍历
	inorder(root); //中序遍历
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值