hdu 1588 Gauss Fibonacci(矩阵快速幂)

Gauss Fibonacci

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2090    Accepted Submission(s): 903


Problem Description
Without expecting, Angel replied quickly.She says: "I'v heard that you'r a very clever boy. So if you wanna me be your GF, you should solve the problem called GF~. "
How good an opportunity that Gardon can not give up! The "Problem GF" told by Angel is actually "Gauss Fibonacci".
As we know ,Gauss is the famous mathematician who worked out the sum from 1 to 100 very quickly, and Fibonacci is the crazy man who invented some numbers.

Arithmetic progression:
g(i)=k*i+b;
We assume k and b are both non-nagetive integers.

Fibonacci Numbers:
f(0)=0
f(1)=1
f(n)=f(n-1)+f(n-2) (n>=2)

The Gauss Fibonacci problem is described as follows:
Given k,b,n ,calculate the sum of every f(g(i)) for 0<=i<n
The answer may be very large, so you should divide this answer by M and just output the remainder instead.
 

Input
The input contains serveral lines. For each line there are four non-nagetive integers: k,b,n,M
Each of them will not exceed 1,000,000,000.
 

Output
For each line input, out the value described above.
 

Sample Input
  
  
2 1 4 100 2 0 4 100
 

Sample Output
  
  
21 12
 

Author
DYGG
 

Source
 


题解及代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int mod=1e9;
struct mat
{
    __int64 t[4][4];
    void set()
    {
        memset(t,0,sizeof(t));
    }
} a,b,c;

mat multiple(mat a,mat b,int n,int p)
{
    int i,j,k;
    mat temp;
    temp.set();
    for(i=0; i<n; i++)
        for(j=0; j<n; j++)
        {
            if(a.t[i][j]!=0)
                for(k=0; k<n; k++)
                    temp.t[i][k]=(temp.t[i][k]+a.t[i][j]*b.t[j][k]+p)%p;
        }
    return temp;
}

mat quick_mod(mat b,int n,int m,int p)
{
    mat t;
    t.set();
    for(int i=0;i<n;i++) t.t[i][i]=1;
    while(m)
    {
        if(m&1)
        {
            t=multiple(t,b,n,p);
        }
        m>>=1;
        b=multiple(b,b,n,p);
    }
    return t;
}

void init1()
{
   b.set();
   b.t[0][1]=1;
   b.t[1][0]=1;
   b.t[1][1]=1;
}
void init2()
{
    b.t[0][2]=1;
    b.t[1][3]=1;
    b.t[2][2]=1;
    b.t[3][3]=1;
}
int main()
{
    int  _k,_b,_n,M;
    while(cin>>_k>>_b>>_n>>M)
    {
        init1();
        a=quick_mod(b,2,_b,M);
        init1();
        b=quick_mod(b,2,_k,M);
        init2();
        c=quick_mod(b,4,_n,M);

        __int64 ans=0;

        b.t[0][0]=c.t[0][2];
        b.t[0][1]=c.t[0][3];
        b.t[1][0]=c.t[1][2];
        b.t[1][1]=c.t[1][3];

        c=multiple(a,b,2,M);

        ans=c.t[1][0];
        cout<<ans<<endl;
    }
    return 0;
}
/*
F为斐波那契数列:F[0]=0,F[1]=1,F[n]=F[n-1]+F[n-2];
g为一个函数,g(i)=k*i+b;
S[n]=∑F[g(i)]=F[b]+F[k+b]+F[k*2+b]+……+F[k*(n-1)+b]
我们设A为斐波那契数列的初始矩阵,B为转换矩阵
那么S[n]=A*B^b+A*B^(k+b)+A*B^(k*2+b)+……+A*B^((n-1)*k+b)
=A*B^b*(I+B^k+B^(2*k)+……+B^((n-1)*k))
那么我们这里只需要求出A,B^b和I+B^k+B^(2*k)+……+B^((n-1)*k)就可以了
当然前两个比较好求,关键是后面这个,首先我们可以先求出B^k=C
然后在构造一个4*4的矩阵来求和
|C I| 其二次方是|C^2 I+C| 三次方|C^3 I+C+C^2| …… 这样我们就能求出和了。
|0 I|          |0     I|       |0         I|
*/




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值