玲珑杯 B -- Private Value

B -- Private Value

Time Limit:1s Memory Limit:128MByte

Submissions:513Solved:166

DESCRIPTION

The "private value" is the value that occurs, but most infrequent.

An array of integers is given, and you need print the private values of the array.

Please notice that, there might be several private values, and you need print them in increasing order.

INPUT
The first line is an integer T(1 <= T <= 4), indicating the number of test cases.For each case, the first line contains an integer n (n <= 100000).The second line contains n integers a_i (0 <= a_i <= 10^9),
OUTPUT
For each case, print all private values in increasing order in a line.
SAMPLE INPUT
271 1 2 2 3 3 355 3 2 4 1
SAMPLE OUTPUT
1 21 2 3 4 5
SOLUTION
水题,统计出现的次数最少的,排序就过了
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define inf 0x6fffffff
#define LL long long
using namespace std;
int a[110000],p[110000];
int main(){
    int t;
    cin>>t;
    while(t--){
    	int n,k=0,minn=inf,cur=0;
    	cin>>n;
    	for(int i=0;i<n;i++){
            scanf("%d",a+i);
            p[i]=0;
    	}
    	sort(a,a+n);
    	for(int i=0;i<n;i++){
            if(a[k]==a[i]){
                p[k]++;
            }
            else{
                    p[i]++;
                    k=i;

            }
    	}
    	for(int i=0;i<n;i++)if(p[i])minn=min(minn,p[i]);
    	for(int i=0;i<n;i++){
            if(p[i]==minn){
                if(cur)cout<<" ";
                else cur=1;
                cout<<a[i];
            }
    	}
    	cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值