poj 3273 (二分法逼近)


Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers:  N and  M 
Lines 2..  N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500


枚举区间最大值,然后用二分法逼近

代码:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define rep(i,j,k) for(int i=j; i<k; i++)
#define pb push_back
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define ll long long
using namespace std;
const int mod=1e9+7;
char s[2100];
int bk[220],f[50000];
int n,m,k,minn,maxx,ans,cur;
ll x[201000],y[2100];
int nex[4][2]={0,1,1,0,0,-1,-1,0};
int nextt[101000];
int ss(ll mm){
    int le=1;
    ll sum=0;
    rep(i,0,n){
        sum+=x[i];//cout<<sum<<endl;
        if(sum>mm){
            sum=x[i];
            le++;
        }
    }
    return le;
}
ll kmax(ll a,ll b){
    return a>b?a:b;
}
int main()
{
    while(cin>>n>>m){
        maxx=0;
        rep(i,0,n)scanf("%lld",x+i),maxx=kmax(maxx,x[i]);
        ll l=maxx,r=1e9+2;
        while(l<=r){
            ll mm=(l+r)>>1;
            //cout<<l<<' '<<r<<endl;
            int k=ss(mm);
            //cout<<l<<"  "<<r<<endl;
            if(k<=m){
                r=mm-1;
            }
            else l=mm+1;
        }
        cout<<l<<endl;
    }

    return 0;
}
//freopen("C:\\Users\\LENOVO\\Desktop\\read.txt","r",stdin);




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值