poj 1159 (LCS)

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 62709 Accepted: 21852

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

题意:问加入多少个字符使原字符串变成回文串。

分析:设原字符串为S1,将S1翻转变成S2,变成求S1和S2的最长公共子序列,5000*5000超内存,所以用滚动数组。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define rep(a,b,c) for(int a=b;a<c;a++)
#define pb push_back
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define ll long long
using namespace std;

int dp[2][5100];
int main(){
    char a[5100],b[5100];
    int n;
    while(~scanf("%d",&n)){
        scanf("%s",a+1);
        for(int i=1;i<=n;i++)b[n-i+1]=a[i],dp[0][i]=0;
        int k=0;
        for(int i=1;i<=n;i++){
            k=1-k;
            for(int j=1;j<=n;j++){

                if(a[i]==b[j])dp[k][j]=dp[1-k][j-1]+1;
                else dp[k][j]=max(dp[1-k][j],dp[k][j-1]);
            }
        }
        printf("%d\n",n-dp[k][n]);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值