unix-Solaris

对目录操作

  1. 显示当前目录 pwd
  2. 显示目录中的内容(文件列表) ls 如:ls –alh
  3. 切换目录 cd
  4. 创建目录 mkdir
  5. 复制目录 cp –r olddir netdir
  6. 删除目录 rmdir
  7. 删除非空目录 rmdir –r
    许可权问题
    chmod 改变指定文件或目录的访问权限
    chown改变文件或目录所属用户权限
    chgrp改变文件或目录所属组权限

对文件操作

1… 查看文件内容
cat显示文件的内容,若文件很大,可用Ctrl+S和Ctrl+Q键来控制屏幕输出的暂停和继续
more/less 一次一屏地显示文件
head显示文件的开始几行
tail显示文件的结尾几行(-f刷新)
pg分页显示指定文件的内容
2.创建文件
用编辑工具(如vi)或者用cat命令建立文件 如 cat > newfile
3. 复制文件 cp
4. 移动文件或重命名 mv
5. 删除文件 rm
6. 搜索文件 find
7. 链接文件 ln
8. 查找字符串grep

件操作命令目录和文件操作命令

  1. 显示进程状态 ps
  2. 用at命令指定时间执行shell命令程序
  3. 用kill 命令终止某些进程
  4. 用sleep命令暂停命令执行
  5. 用nohup命令使用户退出系统后进程继续执行(与&结合使用)
  6. prstat查看进程和负载(-a参数,可查看进程信息)

网络配置

  1. ifconfig
    ifconfig –a检测网络端口状态
    ifconfig le0 IP地址 netmask 子网掩码(配置网络端口地址)
    ifconfig le0 up/down
    ifconfig le0 plumb/unplumb
    2.dladm管理数据链路
  2. ping
  3. telnet
  4. route路由设置
  5. netstat 显示网络状态
    -r :显示路由信息
    -i :显示接口信息

修改网卡
vim /etc/hostname.网卡名
刷新:svcadm restart physical:default
dladm show-phys

设备管理

  1. dmesg显示内核的环形缓冲区信息,可以从中获得诸如系统架构、cpu、挂载的硬件,RAM等多个运行级别的大量的系统信息
  2. format显示磁盘的编号列
  3. sysdef查看系统变量设置
  4. prtconf 打印系统配置(-D参数)
  5. iostat报告有关磁盘输入和输出的统计信息
  6. psrinfo 显示有关处理器信息,每个物理处理器可支持多个虚拟处理器。(-p显示系统中物理处理器数目,与-v选项结合使用时,报告每个物理处理器的附加信息。)
  7. prtdiag 可显示系统上的系统配置信息(-v详细模式)
  8. modinfo显示所有模块信息
  9. zfs 配置zfs文件系统
  10. zpool 配置zfs存储池
  11. lsiutil.i386 查看SAS卡信息

系统资源

  1. df显示磁盘空间的统计信息
  2. du显示目录、子目录和文件的大小
  3. who显示当前正在在线的用户
  4. date获取系统当前时间
  5. env显示当前环境变量
  6. tar备份命令,解压压缩
  7. passwd修改用户口令
  8. svcs查看系统服务状态
  9. svcadm系统服务管理,可以通过参数把相关服务开启或关闭(disable/enable)

查看系统信息

1.prtdiag 查看系统硬件信息
2.uname显示计算机系统信息,如uname –X
3. hostname显示主机名
4. hostid显示主机hostid
5. id显示用户与组的ID和名称
6. pkginfo查看本机安装的各种软件包
7. pkginfo –l xxx查看软件包的具体详细信息

常用指令
修改系统时间 date 1031104501 (10月31日10点45分01年)

重启网卡
svcadm disable physical:default
svcadm enable physical:default

#查看网卡
dladm show-link
vim /etc/hostname.网卡名

vncserver 开启vnc

如果 libvirtd 失败
更新相关依赖
yum update librbd1
systemctl start libvirtd

svcadm disable/enable tomcat8

svcs tomcat8 查看是否关闭/开启

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
2013年最新版的强悍Unix版本Solaris 11.1系统文件,功能十分强大,不愧是真正血统的Unix系统! Oracle Announces Availability of Oracle Solaris 11.1 and Oracle Solaris Cluster 4.1 Delivers Oracle Database and Java Enhancements, Expanded Mission Critical Cloud Management Capabilities and Advanced Platform Features Redwood Shores, Calif – October 26, 2012 News Facts Oracle today announced general availability of Oracle Solaris 11.1 and Oracle Solaris Cluster 4.1. Oracle Solaris 11 is the first cloud OS that allows customers to build large-scale enterprise-class Infrastructure as a Service (IaaS), Platform as a Service (PaaS) and Software as a Service (SaaS) clouds on a wide range of SPARC and x86 servers and Oracle engineered systems. Oracle Solaris Cluster 4.1 extends high availability and disaster recovery capabilities of Oracle Solaris and includes unique virtual cluster features supporting highly efficient application consolidation with best-in-class availability. Oracle Solaris 11 is already widely in production with thousands of customers with mission critical deployments across industries such as financial services, communications, healthcare, retail, public sector and media and entertainment. Read customer success stories about Oracle Solaris here. Oracle Solaris 11 is also gaining strong momentum among enterprise application vendors with hundreds of applications already qualified for Oracle Solaris Ready status through the Oracle PartnerNetwork (OPN). OPN members can develop, sell and implement their solutions on Oracle Solaris 11 and take advantage of specialized Oracle Solaris resources to expand their market reach. Customers and partners can quickly and safely upgrade to Oracle Solaris 11.1 using the built-in update tools and software repositories available with Oracle Solaris 11. Oracle will host a webcast on November 7, 2012 at 8 a.m. Pacific time on Oracle Solaris 11.1 and Oracle Solaris Cluster 4.1, featuring Markus Flierl, vice president, Oracle Solaris Engineering, Core Technology and Bill Nesheim, vice president, Oracle Solaris Engineering, Platform Software. Register here. This event will also include an interactive chat with core developers of Oracle Solaris and Oracle Solaris Cluster. New and Enhanced Features in Oracle Solaris 11.1 Oracle Solaris 11.1 increases the performance, availability and I/O throughput of the latest Oracle Database technology. A new, optimized shared memory interface between the Oracle Database and Oracle Solaris 11.1 provides 8x faster database startup and shutdown, as well as online resizing of the Oracle Database System Global Area (SGA). Oracle Solaris 11.1 introduces unique new capabilities for optimizing Oracle Database performance. Oracle Solaris 11.1 exposes Oracle Solaris DTrace I/O interfaces that allow an Oracle Database administrator to identify I/O outliers and subsequently isolate network or storage bottlenecks. A new Oracle Solaris DTrace plug-in for Oracle Java Mission Control to enable customers to profile Java applications on Oracle Solaris production systems. New cloud management features add to Oracle Solaris 11’s zero overhead built-in virtualization capabilities across system, network and storage resources, including expanded support for Software Defined Networks (SDN) with Edge Virtual Bridging enhancements, to maximize network resource utilization and manage bandwidth in cloud environments. New built-in memory predictor monitors application memory use and provides optimized memory page sizes and resource location to speed overall application performance. Support for an unprecedented 32 TB of RAM and thousands of CPUs unlocks the full potential of Oracle’s latest server systems. Oracle Solaris Cluster 4.1 Highlights New Oracle Solaris 10 Zone Clusters allow customers to consolidate mission critical Oracle Solaris 10 applications on Oracle Solaris 11 cloud environments. Expanded disaster recovery operations using Oracle’s Sun ZFS Storage Appliance services along with Oracle Solaris Cluster 4.1 to coordinate failover of applications and data to a remote disaster recovery site. Faster application recovery with improved storage failure detection and resource dependencies management. New labeled security capability in Oracle Solaris Zone Clusters provides military grade application separation in highly consolidated mission-critical deployments using Oracle Solaris 11 Trusted Extensions. Integrated Oracle Deployments and Support Oracle Enterprise Manager Ops Center provides comprehensive cloud management capabilities for Oracle Solaris 11, including self-service provisioning of Oracle Solaris 11 Zones. Ops Center’s integrated systems management delivers enterprise scale cloud performance. Oracle Enterprise Manager Ops Center is available to Oracle Solaris customers at no additional cost under the Ops Center Everywhere Program. Oracle Solaris Studio delivers the latest in compiler optimizations, multithread performance and powerful analysis tools for native development, and optimized application performance and reliability on Oracle Solaris 11.1 systems. Oracle Solaris 11 guarantees binary compatibility with previous Oracle Solaris versions through the Oracle Solaris Binary Application Guarantee Program, which provides customers a seamless upgrade path and the industry’s best investment protection. Oracle Solaris Legacy Containers allows older Oracle Solaris environments to be brought forward onto latest generation hardware to provide power, cooling and footprint consolidation savings. OPN members can find Oracle Solaris tools and resources in the Oracle Solaris Knowledge Zone, including Oracle Solaris Ready, Oracle Solaris 11 Specialization and Oracle Solaris Development Initiative. The Oracle Solaris Remote Lab now provides a secure cloud environment for OPN members to test and validate their applications with Oracle Solaris 11 in SPARC and x86 virtual environments. Supporting Quotes “Oracle recommends Oracle Solaris 11 for all UNIX®-based Oracle implementations. Oracle Solaris 11.1 delivers over 300 new performance and feature enhancements and is engineered together with Oracle Database, middleware, applications to increase performance, streamline management and automate support for Oracle deployments,” said John Fowler, executive vice president, Systems, Oracle. “The combination of the secure, highly available capabilities of Oracle Solaris Cluster 4.1 and the built-in virtualization of Oracle Solaris 11.1 helps customers bring their most mission-critical applications into a cost effective, agile cloud environment and delivers extreme availability for enterprise applications.” “Clients are looking for ways to reduce the complexity of systems management while enabling Platform as a Service (PaaS) & Software as a Service (SaaS) clouds,” says Lee Diamante, solutions architect, Systems Computing Solutions at Forsythe. “The value of Oracle Solaris 11 is that it maintains all the enterprise-class features expected with a mission-critical OS, while bringing in new, innovative technologies. Forsythe has a long and rich history of delivering customer solutions on Oracle Solaris systems. This is why we are excited about the Solaris 11.1 release.” “Oracle is making it much easier for partners like Informatica to gain access to their software with the new testing environments; shrinking the time to measurable results and value,” said Julie Lockner, vice president, ILM, Informatica. “With the release of Oracle Solaris 11.1 Informatica customers now have access to mission critical deployments across major industries, with an environment of high performance and high availability. With all the new feature enhancements, we look forward to making the Informatica Platform certified on the Oracle Solaris 11 product family.”
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值