B - Corn Fields(修改注释)

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input
Line 1: Two space-separated integers:  M and  N 
Lines 2..  M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output
Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0
Sample Output
9
Hint
Number the squares as follows: 
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

      题意(转载):农夫FJ有一块n行m列的矩形土地, 有的土地是肥沃的,可以在这些土地上放牛(用1表示),有的土地不能放牛(用0表示),而且相邻的可以放牛的格子不能同时有牛,问FJ一共有多少种放牛的方案(一头牛都不放也是一种方案)。

      先把地图换成二进制再压缩到mp【】。再对放牛的(1<<m)种方案进行预处理,只留下没有相邻牛的K种方案存入vis【】。

代码如下:

#include<iostream>
using namespace std;
const int MAX=13;
const int MOD=100000000;
int mp[MAX];
int vis[1<<MAX];
int dp[MAX][1<<MAX];
int judge(int x)
{
    return x & (x<<1);
}
int ok(int x, int y)
{
    return x & y;

}
int main()
{
    int N, M, MM, K, x;
    cin>>N>>M;
    for(int i=1; i<=N;i++)
    {
        for(int j=1; j<=M; j++)
        {
            cin>>x;
            if(!x)
//x是反着存的,在做与运算的时候,可以放牛的地方是和0相与,得结果是否为1
            {
                mp[i]+=(1<<(j-1));//把第i行转化为十进制表示的二进制数 
            }
        }
    }
    MM=1<<M;//M列  MM表示为M为的二进制数最大值
    K=0;
    for(int i=0; i<MM; i++)
    {
        if(!judge(i))//预处理1-MM,如果是0则说明 相邻的没有相同的
            vis[++K]=i;//存起来
    }
    for(int i=1; i<=K; i++)
    {
        if(!ok(vis[i], mp[1]))//如果是0,
            dp[1][i]=1;
    }
    for(int i=2; i<=N; i++)
    {
        for(int j=1; j<=K; j++)
        {
            if(ok(vis[j], mp[i]))//如果vis[] & mp[]
                continue;
            for(int l=1; l<=K; l++)//枚举上一层的状态
            {
                if(!ok(vis[l], mp[i-1]) && !ok(vis[j], vis[l]))
                    dp[i][j]+=dp[i-1][l];
            }
        }
    }
    int ans=0;
    for(int i=1; i<=K; i++)
    {
        ans+=dp[N][i];
        ans%=MOD;

    }
    cout<<ans<<endl;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值