G - Survival

The King of Fighter 97 (KOF97) is an electronic game of wrestling type. Once it was fashionable among youths. The game is amused. However, playing by oneself is not as excited as with friends. Getting bored? Maybe you can alter to the survival mode.

In the survival mode, you play as usual, but under quite unfair conditions: you must use your only character to beat all the other characters and Orichi as well (who is the BOSS)!!! How can you do that? We know that usually we will consume some HP of the character to beat one opponent. Although the character will recover some HP after beating one opponent, the amount of HP recovered is affected by the time you used, so it��s possible that the character lose some HP after one round. What��s worse, if the HP of your character is not enough for you to beat your opponent, you lose!

Given the HP of your character you need to consume and the HP your character will recover if you win for every opponent, you are to determine whether you can clear the game.

NOTE:
1. The initial HP of your character is 100.
2. You can challenge your opponents in any order except that Orichi is always the last one.
3. If your HP falls BELOW zero after any fights (before recovery), you will get your mission failed. 4. Your HP should never exceed 100.


Input


There are multiple test cases, which are separated by a blank line. The first line of each test case is a single integer N (1 <= N <= 20), gives the number of opponents you need to beat. The following N �C 1 lines each contain two integers C and R (0 <= C, R <= 100), where C for the HP you need to consume to beat the opponent and R for the HP recovered after you beat the opponent. The last line contains only one integer P (0 <= P <= 100), describing the HP you need to consume to beat Orichi.


<b< dd="">

Output


For each test case, generate one line of output: if you can clear the game, print "clear!!!" otherwise print "try again" (both without quotations).


<b< dd="">

Sample Input


3
50 50
40 40
70


<b< dd="">

Sample Output


clear!!!

      题意:有N个boss,其中有N-1个小boss必须先全部打完才能打第N个大BOSS,打一个小boss要耗体能consume,打完后恢愎一部分recover,一开始体能为100,在打的过程中也最多为100,问能打完全部的BOSS? 能 输出clear!!!  不能输出try again。

      这里用dp【i】表示打完第i个剩下的体能。先对前N-1个进行dp,最后大boss直接看血量够不够就好了。

代码如下:

#include<iostream>
#include<cstring>
using namespace std;
struct Node
{
    int c;
    int r;
}node[25];
int dp[1100000];//打完第i个剩下的体能
int main()
{
    int N, M;
    while(cin>>N && N)
    {
        for(int i=0; i<N-1; i++)
        {
            cin>>node[i].c>>node[i].r;
        }
        cin>>node[N-1].c;
        memset(dp, -1, sizeof(dp));
        dp[0]=100;
        M=1<<(N-1);
        for(int i=1; i<M; i++)
        {
            dp[i]=-1;
            for(int j=0; (1<<j)<=i; j++)//i状态中最后一个
            {
                if(i & (1<<j) && dp[i-(1<<j)]>=node[j].c)
                {
                    int HP=dp[i-(1<<j)]-node[j].c+node[j].r;
                    if(HP>100)//最大100
                        HP=100;
                    if(HP>dp[i])
                        dp[i]=HP;
                }
            }
        }
        if(dp[(1<<(N-1))-1]>=node[N-1].c)
            cout<<"clear!!!"<<endl;
        else
            cout<<"try again"<<endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值