1087: Undercut

 1087: Undercut


StatusIn/OutTIME LimitMEMORY LimitSubmit TimesSolved UsersJUDGE TYPE
stdin/stdout3s8192K2264657Standard
Undercut is a card game where two players each have five cards numbered one through five. At each round, each player selects a card, then simultaneously reveals it. If the cards are of equal value, there is no score. Otherwise, there are two cases: the two cards are exactly one point apart (this is called an undercut), or the cards are more than one point apart. In the latter case, the person revealing the larger of the cards gets the number of points on the larger card. In the case of an undercut the player with the lower card gets the sum of the two cards. The exception to this is when the cards are 1 and 2, in which case the player with the lower card gets 6 points (instead of only 3 points). After each round, the cards are returned to the hands and they play another round.

For example, if there are 5 rounds and player A plays (in this order) 5, 3, 1, 3, 5 and player B plays 3, 3, 3, 3, 4, then the scoring for each round would be: A gets 5 points, no points, B gets 3 points, no points, B gets 9 points. The totals would be A: 5, B: 12.

In this problem you will be given card plays for both players and must determine the final scores.

Input

There will be multiple input instances. Each instance will be one game. The first line of input for a game will be an integer n <= 20. (A value of n = 0 terminates input.) The next two lines will each contain n integers between 1 and 5 inclusive indicating the cards played on each of n rounds. The first line are player A's card plays and the second line are player B's card plays.

Output

Each input instance should generate one line of output of the form:

A has a points. B has b points.

where the value of a and b are for you to determine. A blank line should separate output lines.

Sample Input

5
5 3 1 3 5
3 3 3 3 4
4
2 3 1 1
1 5 5 5
0

Sample Output

A has 5 points. B has 12 points.

A has 0 points. B has 21 points.
#include<stdio.h>
int main()
{
 int n,i,m=0;
 int a[21],b[21];
 while(scanf("%d",&n),n)
 {
  if(m==0) m++;
  else
   printf("/n");
  int count_a=0,count_b=0;
  for(i=0;i<n;i++)
   scanf("%d",&a[i]);
  for(i=0;i<n;i++)
   scanf("%d",&b[i]);
  for(i=0;i<n;i++)
  {
   
   if(a[i]==1&&b[i]==2) count_a+=6;
   else if(a[i]==2&&b[i]==1) count_b+=6;
   else if(a[i]<b[i]&&(b[i]-a[i])==1) count_a+=(a[i]+b[i]);
   else if(a[i]<b[i]&&(b[i]-a[i])!=1) count_b+=b[i];
   else if(a[i]>b[i]&&(a[i]-b[i])==1) count_b+=(a[i]+b[i]);
   else if(a[i]>b[i]&&(a[i]-b[i])!=1) count_a+=a[i];
   else ;
  }
  printf("A has %d points. B has %d points./n",count_a,count_b);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值