2510: Product

 2510: Product


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
1s16384K504157Standard

There are multiple test cases, the first line of each test case is a integer n. (2<=n<=20) The next line have n integers (every integer in the range [1,1000]). We can divide these n integers into two parts and get the sum of the integers in these two parts, define them as sumA and sumB. Please calc the max number of sumA*sumB and output it in a single line.

Sample Input

3
5 3 7
2
4 9

Sample Output

56
36

Hint

(5,3),(7)  sumA=8  sumB=7  sumA*sumB=56
(5),(3,7)  sumA=5  sumB=10 sumA*sumB=50
(3),(5,7)  sumA=3  sumB=12 sumA*sumB=36
(),(3,5,7) sumA=0  sumB=15 sumA*sumB=0
The max is 56.

 

Problem Source: xwbsw

 


This problem is used for contest: 120 

 

#include<stdio.h>
#include<string.h>
int n,max;
int a[30];
int vis[30];
int sum_all;
void dfs(int id,int sum_now)
{
    int i;
    if(id==n) {if(sum_now*(sum_all-sum_now)>max) max=sum_now*(sum_all-sum_now);return ;}
    for(i=id;i<n;i++)
    {
       
       
            vis[i]=1;
            dfs(i+1,sum_now+a[i]);
            vis[i]=0;
       
    }
}
int main()
{
    while(scanf("%d",&n)==1)
    {
        sum_all=0;
        for(int i=0;i<n;i++) {scanf("%d",&a[i]);sum_all+=a[i];}
        memset(vis,0,sizeof(vis));
        max=0;
        dfs(0,0);
        printf("%d/n",max);
    }
    return 0;
}

 

 

 

 

 

#include<stdio.h>
int a[100],sum;
int n;
int maxn;
void dfs(int id,int temp)
{
    if(id>n)
    {
        if(temp*(sum-temp)>maxn)
        {
            maxn=temp*(sum-temp);
        }
        return ;
    }
    dfs(id+1,temp);
    dfs(id+1,temp+a[id]);
}
int main()
{

    while(scanf("%d",&n)==1)
    {
        sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        maxn=0;
        dfs(1,0);
        printf("%d/n",maxn);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值