2512: Groups

2512: Groups


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s16384K452121Standard

将N个人分成M组,测试数据包含多组输入,每组输入第一行为两个整数N,T(1<=N<=10000),(1<=T<=10000),后面有T行输入,每行两个整数a,b(1<=a,b<=N),表示编号为a的人和编号为b的人在同一组中,根据已知条件求组数M至多为多少。

Sample Input

5 3
1 2
2 3
4 5
6 4
1 2
2 1
3 4
4 3

Sample Output

2
4

 

Problem Source: xwbsw

 


This problem is used for contest: 120 

 

#include<iostream>
using namespace std;
int father[10005],n,t,rank[10005];
int find(int x)
{
    if(father[x]!=x)
    {
        father[x]=find(father[x]);
    }
    return father[x];
}
void uion(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
    {
    if(rank[x]>rank[y])
    {
        father[y]=x;
    }
    else
    {
        if(rank[x]==rank[y])
        {
            rank[y]++;
        }
        father[x]=y;
    }
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&t)==2)
    {
        for(i=1;i<=n;i++)
        {
            father[i]=i;
            rank[i]=0;
        }
        for(int l=0;l<t;l++)
        {
            scanf("%d%d",&i,&j);
            uion(i,j);
        }
        int countc=0;
        for(i=1;i<=n;i++)
        {
            if(father[i]==i)
            {
                countc++;
            }
        }
        cout<<countc<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值