2285: Decompose

2285: Decompose


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K267149Standard
Give you an positive integer N(1<=N<=30), you can decompose n to several positive integers: A1, A2, ... Ak. (1<=k<=N) And A1 + A2 + ... + Ak = N. Now i want to know what's the maximal product of these k integers.

Input

The input contains several test cases. For each test case it contains a positive integer N. The end of input is indicated by end-of-file.

Ouput

For each test case, output K, here K is the maximal product of decomposed numbers.

Sample Input

3
5
6

Sample Output

3
6
9

 

Problem Source: sharang

#include<stdio.h>
int main()
{
    int a[35]={0,1,2,3,4};
    int i,j,n;
    for(i=5;i<=30;i++)
    {
        for(j=1;j<=i/2;j++)
        {
            int t=a[j]*a[i-j];
            if(t>a[i]) a[i]=t;//动态规划
        }
    }
    while(scanf("%d",&n)==1)
    {
        printf("%d/n",a[n]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值