1016: Degrees of separation

1016: Degrees of separation


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K1088438Standard

Find out how many people separate one person from another.
The number of people will be no more than 20.

Input

 

A positive integer representing the number of people in the following list. Each line in the list contains the name of a person, followed by the number of people that person knows, followed by the names of those people. Following this list is a positive integer denoting the number of cases. Each case consists of a starting name and a goal name. Names will not contain any blanks or non-alphabetic characters.

Output


The phrase “<start> has no connection to <goal>.” or the phrase “<start> is separated from <goal> by <num> degrees.”, where <start> is the starting name, <goal> is the goal name, and <num> is the number of degrees of separation between the two.

Sample Input

5
Bob 3 Tom John Jim
Sam 2 Bob John
John 2 Tom Bob
Tom 1 Sam
Jim 0
3
Jim Sam
Sam John
John Sam

Sample Output

Jim has no connection to Sam.
Sam is separated from John by 0 degrees.
John is separated from Sam by 1 degrees.
#include<iostream>
#include<string>
using namespace std;
string name[30];
int main()
{
    int n,m,i,j,k,a[30][30];string str;
    for( i=0;i<30;i++) for(j=0;j<30;j++) a[i][j]=(1<<28);
    for(i=0;i<30;i++) a[i][i]=0;
    int l=0;
    cin>>n;
    for(int ci=0;ci<n;ci++)
    {
        cin>>str>>m;
        int flag=1,pos=0;
        for(i=0;i<l;i++)  if(name[i]==str) {flag=0;pos=i;break;}
        if(flag) {name[l++]=str;pos=l-1;}
        while(m--)
        {
            string s;
            cin>>s;
            int f=1,p=0;
            for(i=0;i<l;i++)  if(name[i]==s) {f=0;p=i;break;}
            if(f) {name[l++]=s;p=l-1;}
            a[pos][p]=1;
        }
    }
 //for(i=0;i<n;i++) cout<<name[i]<<"..." ;cout<<"............"<<endl;
 //for(i=0;i<n;i++) {for(j=0;j<n;j++) cout<<a[i][j]<<"....";cout<<endl;}cout<<"........"<<endl;
    for(k=0;k<n;k++)
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                if(a[i][j]>a[i][k]+a[k][j]) a[i][j]=a[i][k]+a[k][j];
 //for(i=0;i<n;i++) {for(j=0;j<n;j++) cout<<a[i][j]<<"....";cout<<endl;}
    int num;
 cin>>num;
    while(num--)
    {
        string p1,p2;
        int pos1,pos2;
        cin>>p1>>p2;
        for(i=0;i<n;i++) if(name[i]==p1) {pos1=i;break;}
        for(i=0;i<n;i++) if(name[i]==p2) {pos2=i;break;}
        int len=a[pos1][pos2]-1;
        if(len>(1<<20)) cout<<p1<<" has no connection to "<<p2<<"."<<endl;
        else cout<<p1<<" is separated from "<<p2<<" by "<<len<<" degrees."<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值