2163: The Matrix

 2163: The Matrix


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K390166Standard
Consider this method to describe a binary tree:
  • We name the root node 'A',that means All other's parent.
  • If a node's name is s (s is a string), its left child node's (if there is one) name is sL, and its right child node's name is sR.
Following these two rules, a tree may look like this:
       A
      / /
     /   / 
    AL   AR
     /
      /
      ALR
      / 
     /
   ALRL
Now we give you some node's name in random order, can you give the preorder traversal of the tree?

Note: a preorder traversal is: for any node you have to print its own's name first, then traversal its left sub tree, and then its right sub tree. For the tree above, the preorder traversal is like this: A, AL, ALR, ALRL, AR

Input

There are several test cases. For each case, the first line is a integer n (0 < n <= 10000) which tell you how many nodes you'll have to read, followed by n strings, each is a node name.

Output

Print the node names in preorder traversal, one name per line.

Print a blink line after each test case.

Sample Input

5
AL AR ALRL ALR A
1
A

Sample Output

A
AL
ALR
ALRL
AR

A

 

Problem Source: fafey

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
    string a[10000];
    int n;
    while(cin>>n)
    {
        for(int i=0;i<n;i++) cin>>a[i];
        sort(a,a+n);
        for(int i=0;i<n;i++) cout<<a[i]<<endl;
        cout<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值