Max Angle
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 342 Accepted Submission(s): 128
Problem Description
Given many points in a plane, two players are playing an interesting game.
Player1 selects one point A as the vertex of an angle. Then player2 selects other two points B and C. A, B and C are different with each other. Now they get an angle B-A-C.
Player1 wants to make the angle as large as possible, while player2 wants to make the angle as small as possible.
Now you are supposed to find the max angle player1 can get, assuming play2 is c lever enough.
Player1 selects one point A as the vertex of an angle. Then player2 selects other two points B and C. A, B and C are different with each other. Now they get an angle B-A-C.
Player1 wants to make the angle as large as possible, while player2 wants to make the angle as small as possible.
Now you are supposed to find the max angle player1 can get, assuming play2 is c lever enough.
Input
There are many test cases. In each test case, the first line is an integer n (3 <= n <= 1001), which is the number of points on the plane. Then there are n lines. Each contains two floating number x, y, witch is the coordinate of one point. n <= 0 denotes the end of input.
Output
For each test case, output just one line, containing the max angle player1 can get in degree format. The result should be accurated up to 4 demicals.
Sample Input
3 0 0 2 0 0 5 -1
Sample Output
90.0000#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const double pi=acos(-1+0.0);//0.0 important
struct node
{
double x,y;
};
double dis(node a, node b)
{
return sqrt((a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y));
}
int main()
{
int n;
node a[1100];
double t[1100];
while(scanf("%d",&n)==1&&n>0)
{
for(int i=0;i<n;i++) scanf("%lf%lf",&a[i].x,&a[i].y);
double cnt=0;
for(int i=0;i<n;i++)//枚举顶点 important
{
int l=0;//极角排序,排的是各点到顶点的角度(相对x轴),在顶点下面的点要用2*pi-angle
for(int j=0;j<n;j++)
{
if(i==j) continue;
t[l++]=acos((a[j].x-a[i].x)/dis(a[i],a[j]));//用acos important
if(a[j].y<a[i].y) t[l-1]=2*pi-t[l-1];//考虑在点下方 important
}
sort(t,t+l);
double _min=2*pi-t[l-1]+t[0];//第一个点和最后一个点之间的夹角 important
for(int i=1;i<l;i++) if(t[i]-t[i-1]<_min) _min=t[i]-t[i-1];//找相邻的夹角 important
if(_min>cnt) cnt=_min;
}
printf("%.4lf/n",cnt*180/pi);
}
return 0;
}