poj 2002 Squares 判断一些点能组成多少个正方形 二分查找

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 8864 Accepted: 3088

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <cstdio>
using namespace std;
struct node
{
    int x, y;
} p[1001];
bool op(const struct node &xx, const struct node &yy)
{
    if (xx.x == yy.x)
        return xx.y < yy.y;
    else
        return xx.x < yy.x;
}
int main()
{
    int points;
    while (scanf("%d", &points), points)
    {
        int sum = 0;
        for (int i = 0; i < points; ++i)
            scanf("%d%d", &p[i].x, &p[i].y);
        sort(p, p + points, op);
        for (int i = 0; i < points; ++i)
        {
            for (int j = i + 1; j < points; ++j)
            {
                //已知正方形两点的坐标(是正方形的一边),求另两点
                //p[i]--p1,p[j]--p0
                node p0, p1;
                p0.x = p[i].x + p[j].y - p[i].y;
                p0.y = p[i].y + p[i].x - p[j].x;
                p1.x = p[j].x + p[j].y - p[i].y;
                p1.y = p[j].y + p[i].x - p[j].x;
                if (!binary_search(p, p+points, p0, op))
                    continue;
                if (!binary_search(p, p+points, p1, op))
                    continue;
                sum++;
            }
        }
        printf("%d/n", sum / 2);//最后要除以2
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值