poj 1305 Fermat vs. Pythagoras 求小于等于N的素勾股数的个数 暴力方法

Description

Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and current efforts in verification have succeeded in verifying the translation of high-level code down to the chip level. 
This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of a^n + b^n = c^n for n > 2. 
Given a positive integer N, you are to write a program that computes two quantities regarding the solution of x^2 + y^2 = z^2, where x, y, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x < y < z, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values 0 < p <= N such that p is not part of any triple (not just relatively prime triples). 

Input

The input consists of a sequence of positive integers, one per line. Each integer in the input file will be less than or equal to 1,000,000. Input is terminated by end-of-file

Output

For each integer N in the input file print two integers separated by a space. The first integer is the number of relatively prime triples (such that each component of the triple is <=N). The second number is the number of positive integers <=N that are not part of any triple whose components are all <=N. There should be one output line for each input line.

Sample Input

10
25
100

Sample Output

1 4
4 9
16 27

//


#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
///x=2*a*b,y=a^2-b^2,z=a^2+b^2,其中a>b>0,(a,b)=1,a和b有不同的奇偶性。
int vis[1000001];
int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        memset(vis,0,sizeof(vis));
        int tot=0;
        for(int i=1;i<=int(sqrt(n/2.0));i++)
        {
            for(int j=i+1;j<=int(sqrt(n/1.0));j++)
            {
                if(!(gcd(i,j)==1&&(i%2!=j%2))) continue;
                int x=j*j-i*i;
                int y=2*j*i;
                int z=i*i+j*j;
                if (z>n) break;
                if (gcd(x,y)==1&&gcd(x,z)==1&&gcd(y,z)==1)
                {
                    tot++;
                    for (int k=1;k<=n/z;k++)
                    vis[x*k]=vis[y*k]=vis[z*k]=1;
                }
            }
        }
        int tt=0;
        for(int i=1;i<=n;i++) if (vis[i]==0) tt++;
        printf("%d %d\n",tot,tt);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值