河南省第六届大学生程序设计竞赛——Card Trick

                                           Card Trick

题目描述

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

1. The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.

2. Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.

3. Three cards are moved one at a time…

4. This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of

the cards for a given number of cards, 1 ≤ n ≤ 13.

输入

On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10  Each case consists of one line containing the integer n.  1 ≤ n ≤ 13

输出

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

样例输入

2
4
5

样例输出

2 1 4 3
3 1 4 5 2

题意描述:

给你n张牌,让你变一个魔术:第1次把上面的1张牌放到底部,然后最上面的牌就是1,然后拿走1。第2次把上面的2张牌依次放到底部,然后最上面的牌就是2,然后拿走2....重复这个过程,直到所有的牌都被拿走。问一开始的牌应该从上到下怎么放,才能完成这个魔术。

解题思路:

直接模拟,倒着推存入数组中。

程序代码:
 

#include<stdio.h>
int main()
{
	int a[20];
	int i,j,t,n,k,u,v,s;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		k=1;
		for(i=n;i>=1;i--)
		{
			a[k++]=i;
			for(j=1;j<=i;j++)
			{
				u=a[1];
				for(v=1;v<k-1;v++)
				{
					a[v]=a[v+1];
				}
				a[k-1]=u;
			}
		}
		for(i=n;i>1;i--)
			printf("%d ",a[i]);
		printf("%d\n",a[1]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值